



Test Case Hydroview
for 

Contract DG133W-05-CQ-1067

Advanced Weather Interactive Processing System (AWIPS)
Operations & Maintenance

AWP.TE.SWCTR/TO10-0008
Prepared for:

U.S. Department of Commerce

NOAA/NWS Acquisition Management Division

SSMC2, Room 11220
1325 East-West Highway

Silver Spring, MD 20910

Prepared by:

Raytheon Company

STC Office

6825 Pine Street

Omaha, NE 68106 

21 November 2008
Submitted By:
___________________________________________________________
___________

Test Engineer








Date

Approved By:

___________________________________________________________
__________

Program Manager







Date

___________________________________________________________
__________

Mission Assurance Quality






Date

Change History

	Revision
	Date
	Affected Pages
	Explanation of Change

	Draft
	21 Nov. 2008
	ALL
	Initial Draft


Table of Contents
Page

11.0
Scope


22.0
APPLICABLE DOCUMENTS


22.1  Source Documents


22.2  Reference Documents


33.0
Test Case description


33.1  Assumptions, Constraints and Preconditions


33.2  Recommended Hardware


33.3  Test Inputs


33.4  Test Outputs


44.0
TEST SCENARIO


385.0
requirements verification traceability matrix (RVTM)




1.0 Scope

See TO10 Software Test Plan.

2.0 APPLICABLE DOCUMENTS

2.1 Source Documents

· None

2.2 Reference Documents

· Legacy NWS Test Cases: Baseline_HYDRO_WHFS_Hydroview (OB8.3); Baseline_HYDRO_WHFS_Hydroview_OB8.1; Baseline_HYDRO_PointData.Control; Checkout_4.4.2_Hydroview_OB8.1.
· Software Test Plan for the Advanced Weather Interactive Processing System Project, Contract #DG133W-05-CQ-1067, January 2009.
· The Silver Spring NWS AWIPS 1 test bed application.
· Rational RequisitePro.
3.0 Test Case description
The purpose of this Test Proceduretc \l1 "WHFS Hydrologic Database Manager Software Capability Test Case is to test and verify the functionality found within the current version of the WHFS Hydrologic Data Viewer application known as Hydroview. Also demonstrated in this test case is the Point Data Control functionality. As new functionality is added to this application, these test procedures will be updated to contain the steps required to test this new functionality.
3.1 Assumptions, Constraints, and Preconditions

· TO10 software has been installed successfully.
· CAVE, EDEX, and pgAdmin III are running.
· Data has been ingested. 

· Actions, Results, and Requirements highlighted in yellow indicate requirements and/or capabilities to be included in the scope of future task orders. They are included here for purposes of continuity and traceability with the original AWIPS I test case documents. Note that Pan and Zoom capabilities highlighted in yellow will be demonstrated following an approach consistent with current CAVE capabilities. Differences in approach from AWIPS I Hydroview may result in a variance or later revision.
3.2 Recommended Hardware

See TO10 Software Test Plan.

3.3 Test Inputs

Section 4.0 contains the test procedures for this test case. Sections 2.2 – 2.9 of the TO10 Software Test Plan contain general test inputs applicable to all TO10 test cases. 
3.4 Test Outputs

The results outlined in section 4.0 are met.
4.0 TEST SCENARIO
	Step #
	Action
	Result
	Pass/Fail

	1. 
	In CAVE, Mouse Button (MB) 1 click on the Perspectives icon and select ‘Hydro’ from the dropdown menu if available. If not available, select ‘Other…’. Then select ‘Hydro’ from the Open Perspective dialog.
	The Hydro Perspective displays in CAVE.
	

	2. 
	From the ‘MapData’ pull-down menu, select ‘Point Data Control…’.
	The Point Data Control window opens and the stations display in the Hydroview main window.
	

	3. 
	MB1 click the ‘Close’ button.
	The Point Data Control window closes.
	

	4. 
	From the ‘Help’ pull-down menu, select ‘About’.
	An About window displaying the application’s name, version number and date is shown.
	

	5. 
	On the About window, MB1 click the ‘OK’ button.
	The About window closes.
	

	6. 
	From the ‘Help’ pull-down menu, select ‘Map Legend’.
	This window displays a legend for Station icons and colors. These are the station icons and colors used by the Point Data Control option. Note: To make sure some stations exist in the Hydroview main window.
	

	7. 
	MB1 click the ‘Close’ button from the Station Legend window.
	The Station Legend window closes.
	

	8. 
	From the File pull-down menu, select ‘Save as Gif’.
	The Save as GIF window launches.
	

	9. 
	In the Save as GIF window, use the Filter and Directories selection boxes to choose a directory to save a GIF screen capture. In the Selection box, enter the name of the file to save the screen capture to (including the directory) followed by the ‘.gif’ file extension. For best results move the Save as GIF window off of the Hydroview display. MB1 click the ‘OK’ button.
	The Save as GIF window closes.
	

	10. 
	In a terminal, go to the directory where the screen capture was saved. Use the “display” command to display the GIF file.
	The Hydroview screen capture displays.
	

	11. 
	From the ‘File’ pull-down menu, select ‘Print Image’.
	The Hydroview image is sent to the printer specified by the whfs_printcommand_LX token.
	

	12. 
	From the ‘File’ pull-down menu, select ‘Print Reverse Image’.
	The Hydroview image is sent to the printer specified by the whfs_printcommand_LX token. The image will be displayed in reverse video (i.e., black as white and white as black).
	

	13. 
	From the ‘Tools’ pull-down menu, select ‘Point Zoom’ -> ‘Out’.
	The center of the geographic display is zoomed out.
	

	14. 
	From the ‘Tools’ pull-down menu, select ‘Point Zoom’ -> ‘In’. 
	The center of the geographic display is zoomed in.
	

	15. 
	Draw a rectangle on the geographic display by holding down the MB1. Then from the ‘Tools’ pull-down menu, select ‘Areal Zoom’.
	The geographic display zooms in on the rectangular area drawn.
	

	16. 
	From the ‘Tools’ pull-down menu, select ‘Areal Zoom’ again.
	The display returns to its previous zoom level.
	

	17. 
	From the ‘Tools’ pull-down menu, select ‘Pan’ -> ‘Up’.
	The geographic display moves North.
	

	18. 
	From the ‘Tools’ pull-down menu, select ‘Pan’ -> ‘Down’.
	The geographic display moves South.
	

	19. 
	From the ‘Tools’ pull-down menu, select ‘Pan’ -> ‘Right’.
	The geographic display moves East.
	

	20. 
	From the Tools pull-down menu, select ‘Pan’ -> ‘Left’.
	The geographic display moves West.
	

	21. 
	From the ‘Tools’ pull-down menu, select ‘Recenter’.
	The cursor changes from an arrow into a leftward pointing hand that indicates that recenter functionality is active.
	

	22. 
	MB1 click on an area that is not in the center of the display.
	The display is recentered on the selected area.
	

	23. 
	From the ‘Tools’ pull-down menu, select ‘Recenter’ again. Then MB1 click on the area that was originally at the center of the display.
	The geographic display returned to its previous viewing state and center.
	

	24. 
	From the ‘Tools’ pull-down menu, select ‘Tool Bar’.
	A tool bar appears just below the row of pull-down menus. The icons shown perform the same functions as the Zoom and Pan options found in the Tools pull-down menu.
	

	25. 
	From the ‘Tools’ pull-down menu, select ‘Tool Bar’ again.
	The tool bar disappears.
	

	26. 
	From the ‘Tools’ pull-down menu, select ‘Set Font’ -> ‘Small’.
	Alphanumeric text annotations on the Hydroview GUI display in their default, startup size.
	

	27. 
	From the ‘Tools’ pull-down menu, select ‘Set Font’ -> ‘Very Small’.
	Alphanumeric text annotations on the Hydroview display become smaller when compared to previous size.
	

	28. 
	From the ‘Tools’ pull-down menu, select ‘Set Font’ -> ‘Miniscule’.
	Alphanumeric text annotations on the Hydroview display become smaller when compared to previous size. This is the smallest font size.
	

	29. 
	From the ‘Tools’ pull-down menu, select ‘Set Font’ -> ‘Normal’.
	Alphanumeric text annotations on the Hydroview display become normal in font size.
	

	30. 
	From the ‘Tools’ pull-down menu, select ‘Set Font’ -> ‘Large’.
	Alphanumeric text annotations on the Hydroview display become larger.
	

	31. 
	From the ‘Tools’ pull-down menu, select ‘Set Font’ -> ‘Very Large’.
	Alphanumeric text annotations on the Hydroview display become larger than previous size. This is the largest font size.
	

	32. 
	From the ‘Projections’ pull-down menu, select ‘Polar Stereographic’.
	The geographic map displays a Polar Stereographic projection.
	

	33. 
	From the ‘Projections’ pull-down menu, select ‘HRAP’.
	The geographic map displays a HRAP projection.
	

	34. 
	From the ‘Projections’ pull-down menu, select ‘Flat Lat/Lon’.
	The geographic map displays a Flat Latitude / Longitude projection.
	

	35. 
	From the ‘Overlays’ pull-down menu, select ‘Streams/Lakes’ -> ‘No Streams/Lakes’.
	No streams or lakes are shown on the geographic display.
	

	36. 
	From the ‘Overlays’ pull-down menu, select ‘Streams/Lakes’ -> ‘Major Streams/Lakes’.
	All major streams and lakes are shown on the geographic display if defined in the Overlay Configuration file.
	

	37. 
	From the ‘Overlays’ pull-down menu, select ‘Streams/Lakes’ -> ‘All Streams/Lakes’.
	All streams and lakes are shown on the geographic display if defined in the Overlay Configuration file.
	

	38. 
	From the ‘Overlays’ pull-down menu, select ‘Basin Boundaries’.
	This toggles the displaying of Basin Boundary outlines on the geographic display if defined in the Overlay Configuration file.
	

	39. 
	From the ‘Overlays’ pull-down menu, select ‘Counties’.
	This toggles the displaying of County outlines on the geographic display if defined in the Overlay Configuration file.
	

	40. 
	From the ‘Overlays’ pull-down menu, select ‘County Warning Areas’.
	This toggles the displaying of CWA outlines on the geographic display if defined in the Overlay Configuration file.
	

	41. 
	From the ‘Overlays’ pull-down menu, select ‘RFC Boundaries’.
	This toggles the displaying of RFC Boundary outlines on the geographic display if defined in the Overlay Configuration file.
	

	42. 
	From the ‘Overlays’ pull-down menu, select ‘States’.
	This toggles the displaying of State Borders on the geographic display if defined in the Overlay Configuration file.
	

	43. 
	From the ‘Overlays’ pull-down menu, select ‘Zones’.
	This toggles the displaying of Zones on the geographic display if defined in the Overlay Configuration file.
	

	44. 
	From the ‘Overlays’ pull-down menu, select ‘Cities/Towns’.
	This toggles the displaying of City locations on the geographic display if defined in the Overlay Configuration file.
	

	45. 
	From the ‘Overlays’ pull-down menu, select ‘Highways/Roads’ -> ‘Highways’.
	All Highways will be shown on the geographic display if defined in the Overlay Configuration file.
	

	46. 
	From the ‘Overlays’ pull-down menu, select ‘Highways/Roads’ -> ’None’.
	No Highways or Roads are shown on the geographic display.
	

	47. 
	From the ‘Overlays’ pull-down menu, select ‘HRAP’.
	This toggles the display of the HRAP grid on the geographic display if defined in the Overlay Configuration file.
	

	48. 
	From the ‘Overlays’ pull-down menu, select ‘Lat/Lon Lines’.
	This toggles the display of Latitude and Longitude lines on the geographic display if defined in the Overlay Configuration file.
	

	49. 
	From the ‘Overlays’ pull-down menu, select ‘Time Zones’.
	This toggles the display of Time Zone boundaries on the geographic display if defined in the Overlay Configuration file.
	

	50. 
	From the ‘Overlays’ pull-down menu, select ‘Radar Locations’.
	This toggles the display of Radar locations on the geographic display if defined in the Overlay Configuration file.
	

	51. 
	From the ‘Overlays’ pull-down menu, select ‘Radar Rings’.
	This toggles the display of the outline of a Radar’s coverage area on the geographic display if defined in the Overlay Configuration file.
	

	52. 
	On the ‘Overlays’ menu, the grayed out Basin Names listed below will be implemented in a future build:

‘Hydro Service Areas’

‘Topography’

‘Maps Foreground’
	No Action.
	

	53. 
	Double MB1 click on a station icon on the geographic display.
	The selected station is enclosed in a red square. 
	

	54. 
	From the ‘MapData’ pull-down menu, select ‘Station Selection’.
	The Station List window appears. The entry for the station enclosed in the red square on the Hydroview display is highlighted in the Station Selection list.
	

	55. 
	From the ‘Station List’, select another station.
	The station entry in the Station List becomes highlighted. A red rectangle is drawn around the station’s location on the Hydroview display.
	

	56. 
	In the ‘Station List’ window, double MB1 click on a station.
	The time series control window is shown. 
	

	57. 
	On the ‘Hydroview’ display, double MB1 click on another station.
	A red rectangle is drawn around that station on the Hydroview display.
	

	58. 
	From the ‘Station List’ window, scroll down the station list, select another station and then use the ‘Search’ text box to find the station selected in step 59.
	The search feature will find the station in the list, highlight its entry in the station list and draw a red rectangle around its location on the Hydroview display.
	

	59. 
	From the ‘Station List’ window, MB1 click the ‘Cancel’ button.
	The Station List window closes.
	

	60. 
	From the ‘MapData’ pull-down menu, select ‘Refresh Data’.
	This queries the IHFS database and updates the station data shown on the Hydroview display.
	

	61. 
	From the ‘MapData’ pull-down menu, select ‘Dam Locations’.
	The Dam Display Control window opens.
	

	62. 
	Select the ‘Map Data’ push-button on the Dam Display Control window.
	Dam icons along with their names display on the geographic window.
	

	63. 
	The Dam Display Control window provides the option to filter the displayed Dams by volume. Enter a value in the threshold volume text box (e.g. 100000) and then try each of the filters by options:  greater than, equal to, less than, and All. 
Each time a filter option is changed, MB1 click the ‘Map Data’ button.
	The Dam icons are selectively displayed based on their volume, the dam volume threshold value and filter option chosen.
	

	64. 
	The Dam Display Control window allows the displayed dams to be limited within a specific area on the Hydroview display. This is controlled by a user-selectable center point and a latitude/longitude box centered on this point. Try modifying the ‘lat/lon center point’ value and the ‘lat/long offsets’. Toggle the ‘enable’ button and select ‘Map Data’.
	The displayed dams are limited to the defined latitude/longitude box.
	

	65. 
	Select different combinations of the filters (Id, Name and Icon) in the Dam Display Control window. This allows the display to show or hide the Id, Name, and Icon.
	The Data is selectively displayed based on the filter chosen for Id, Name and Icon filters.
	

	66. 
	Place the mouse pointer over a dam location, click and hold MB3 and select ‘DamCrest’ from the popup menu.
	The DamCrest application is launched for the selected dam.

Output Manager window opens.
	

	67. 
	On the Dam Crest application window, MB1 click ‘Close’ from the File pull-down menu.
	The Dam Crest application is closed.
	

	68. 
	Select the ‘Clear Data’ push-button on the Dam Display Control window.
	The Dams will be cleared from the geographic display.
	

	69. 
	From the Dam Display Control window, MB1 click the ‘Close’ button.
	The Dam Display Control window closes.
	

	70. 
	From the ‘MapData’ pull-down menu, select ‘Best Estimate QPE’.
	The Display Best Estimate QPE window opens.
	

	71. 
	From the Display Best Estimate QPE window, MB1 click the ‘Show Data’ button.
	A MPE generated 1 hour Best Estimate QPE field displays in the Hydroview GUI.
	

	72. 
	From the Display Best Estimate QPE window, MB1 click the ‘Time Lapse’ button and use the duration slider bar to set the duration to 6 hours. MB1 click the ‘Show Data’ button.
	A time lapse of 6 hours worth of MPE Best Estimate QPE fields displays in the Hydroview GUI.
	

	73. 
	From the Display Best Estimate QPE window, MB1 click the ‘|<<’ button adjacent to the time lapse toggle button.
	The time lapse stops and enters manual time lapse mode. The oldest QPE field in the time lapse is shown in the Hydroview display (the time of the product is shown in the lower left corner of the display).
	

	74. 
	From the Display Best Estimate QPE window, MB1 click the ‘<’ button to manually step backwards through each frame of the time lapse.
	Each time the ‘<’ button is clicked, the previous QPE frame in the time lapse is displayed.
	

	75. 
	From the Display Best Estimate QPE window, MB1 click the ‘>’ to manually step forward through each frame of the time lapse.
	Each time the ‘>’ button is clicked, the next QPE frame in the time lapse is displayed.
	

	76. 
	From the Display Best Estimate QPE window, MB1 click the restart timelapse button [image: image1.png]


 to restart the automatic time lapse.
	The automatic time lapse resumes.
	

	77. 
	From the Display Best Estimate QPE window, MB1 click the ‘End Lapse’ button.
	The time lapse stops. The Hydroview display shows the Best Estimate QPE field which was displayed before the time lapse was started.
	

	78. 
	From the Display Best Estimate QPE window, MB1 click the ‘Accumulate’ toggle button. Set the duration slider bar to ‘24’. MB1 click the ‘Show Data’ button.
	An accumulation of 24 1-hour Best Estimate QPE fields displays in the Hydroview GUI.
	

	79. 
	From the Display Best Estimate QPE window, select ‘Basin’ from the ‘Display As’ combo box. MB1 click the ‘Show Data’ button. Use the grid, zone and county filters.
	The 24 hour accumulation is displayed as basin averaged precipitation amounts.
	

	80. 
	From the Display Best Estimate QPE window, select ‘day adjust’ and ‘hour adjust’ arrow buttons to increment / decrement the date and time. MB1 click ‘Show Data’.
	The displayed data should have changed according to the data and time selected.
	

	81. 
	From the Display Best Estimate QPE window, MB1 click the ‘Clear Data’ button.
	The QPE data are cleared from the MPE display.
	

	82. 
	From the Display Best Estimate QPE window, MB1 click the ‘Close’ button.
	The Display Best Estimate QPE window closes.
	

	83. 
	From the ‘MapData’ pull-down menu, select ‘Flash Flood Guidance’.
	The Flash Flood Guidance window opens.
	

	84. 
	Select a product from the top or near the top of the list, and MB1 click ‘Select’.
	A color map of zones displays, showing the current Flash Flood threat across the area. Warm colors are threats; cool colors are not threats. If the RFC for the WFO does not produce FFG data, the color for missing displays.
	

	85. 
	Select the ‘FFG Mode Gridded’ toggle button and select ‘WFO’ in the ‘FFG area’ filter. Select a product from the scroll list and MB1 click ‘Select’.
	A color map displays showing the Flash Flood threat across the area for the WFO.
	

	86. 
	With the ‘FFG Mode Gridded’ toggle button set, change the ‘FFG area’ to ‘RFC’. Select a product from the list.
	A color map displays showing the Flash Flood threat across the area for the RFC.
	

	87. 
	With the ‘FFG Mode Gridded’ toggle button set, choose different durations from the ‘Dur’ filter. Select products from the list.
	The color map shows the Flash Flood threat for the selected duration.
	

	88. 
	With the ‘FFG Mode Gridded’ option set, select a product from the list. Test by choosing ‘Basin’ once and ‘Grid’ next time in the ‘Display As’ filter option.
	The color map shows the flash flood threat displayed on an HRAP grid when the Display As filter is ‘Grid’. The color map shows the flash flood threat displayed as averaged basin values when the Display As filter is ‘Basin’.
	

	89. 
	Set the ‘FFG Mode’ to ‘Areal’.
	The product list will update with areal FFG products.
	

	90. 
	With FFG Mode set to Areal, choose different Areal Types (Zone, County, Basin, All) and select products to display for them.
	The areal values display in the Hydroview viewer based on the selected Areal Type filter and the selected product from the FFG product list. The areal values display as colored numbers. The colors of the numbers correspond to the FFG color product legend.
	

	91. 
	With the ‘FFG Mode’ set to ‘Areal’, select different durations from the ‘Dur FFG’ option and display FFG products for them.
	The areal FFG values display for the selected duration.
	

	92. 
	With the ‘FFG Mode’ set to ‘Areal’, select a product from the list and test by selecting/deselecting the toggle buttons for ‘Id’ and ‘Value’.
	The Areal FFG labels displayed on the Hydroview map are based on the toggle selection of the ‘Id’ and ‘Value’. If ‘Id’ is only selected then only Ids will be displayed. This holds the same with ‘Value’ toggle button. If both ‘Id’ and ‘Value’ are selected then both Ids and Values display.
	

	93. 
	MB1 click the ‘Clear’ button in the Flash Flood Guidance window.
	The FFG data are cleared from the Hydroview geographic display.
	

	94. 
	MB1 click the ‘Close’ in the Flash Flood Guidance window.
	The Flash Flood Guidance window closes.
	

	95. 
	From the ‘LiveData’ pull-down menu, select ‘Time Series Graphs/Tables’. 
	The Time Series Control window opens in Station Selection mode with the station selected inside the red square on the Hydroview Display highlighted in the station list. 
	

	96. 
	MB1 click the ‘Close’ button in the Time Series Control window.
	The Time Series Control window closes.
	

	97. 
	From the ‘LiveData’ pull-down menu, select ‘Site Specific Headwater Model’.
	The SSHP application launches for the selected station. If that station is not configured for SSHP, an error dialog appears. Select the ‘OK’ button to close the dialog. 
	

	98. 
	Select the ‘Exit Application’ push-button on the SSHP Control window.
	The SSHP application closes.
	

	99. 
	From the ‘LiveData’ pull-down menu, select ‘Alert and Alarms Data’.
	The Alert and Alarm Data Values window opens. The scroll list shows the alert/alarm data. Also details for the item that is highlighted in the list will appear in the all appropriate text areas that is below the scroll list.
	

	100. 
	Select different values for the show filter: ‘All’ 

‘Observed’ 

‘Forecast’
	The scroll list will have only forecast data if ‘Forecast’ is selected, only observed data if ‘Observed’ is selected and both observed and forecast data if ‘All’ is selected.
	

	101. 
	Select different values for the show filter: ‘Alert&Alarm’ 

‘Alert’ 

‘Alarm’
	The scroll list will have only alert data if ‘Alert’ is selected, only alarm data if ‘Alarm’ is selected and both alert and alarm data if ‘Alert/Alarm’ is selected.
	

	102. 
	Select different values for the exceeding filter:

‘Any Limit’

‘Rate-Of-Change’

‘Upper Limit’

‘Lower Limit’

‘Diff Limit’
	The scroll list will have only rate-of-change data if ‘Rate-Of-Change’ is selected, only data that has exceed upper limit if ‘Upper Limit’ alarm is selected, only data that is lower than the set lower limit if ‘Lower limit’ is selected and all exceeded data if ‘Any Limit’ is selected.
	

	103. 
	Select ‘Sort By Time’.
	The data in the scroll list is displayed with their order sorted by validtime.
	

	104. 
	Select ‘Sort By Location’.
	The data in the scroll list is displayed with their order sorted by location id.
	

	105. 
	Select any item from the scroll list and MB1 click the ‘Delete’ button.
	A dialog asking confirmation to delete appears. If you select ‘Yes’, that item will be deleted.
	

	106. 
	Select ‘Tabular Time Series and Graphical Time Series’ to bring up Time Series window.
	The Time Series Control window opens in Station Selection mode with the selected station highlighted. 
	

	107. 
	Select the ‘Close’ push-button on the Alert and Alarm Data Values window.
	The Alert and Alarm Data Values window closes.
	

	108. 
	From the ‘LiveData’ pull-down menu, select ‘Questionable and Bad Data’.
	The Questionable and Bad Data window opens. Scroll List showing the questionable and bad data displays in the window. The qc description for the item that is highlighted in the list appears in the bottom QC Description box.
	

	109. 
	Select ‘Filter By Location’ and enter a location id. Press the Enter key on the keyboard after entering the location id.
	The scroll list has only the data that is pertaining to the location id provided. If there is not questionable and bad data found for that location id, it will give the message stating the data is unavailable.
	

	110. 
	Select different values for element from the available values:

‘Height’

‘Temperature’

‘Ground’

‘Ice’
	The scroll list has only the data that is pertaining to the selection made. If Temperature is selected, only temperature data is displayed and so on.
	

	111. 
	Enter the number of days (say 11) in the test box available for last days.
	The scroll list has the data that is pertaining to the past 11 days.
	

	112. 
	Select ‘Sort By Location’.
	The scroll list has the data sorted based on location id.
	

	113. 
	Select ‘Sort By Time’.
	The scroll list has the data sorted based on observation time.
	

	114. 
	Select ‘Sort By Shef Quality’.
	The scroll list has the data sorted based on shef quality (the SQ column).
	

	115. 
	Select ‘Sort By Quality Code’.
	The scroll list has the data sorted based on quality code (the QC column).
	

	116. 
	Highlight an item in the scroll list and MB1 click ‘Set Missing’.
	The item is set to have its value missing and the item is removed from the scroll list displayed.
	

	117. 
	Highlight an item in the scroll list and MB1 click ‘Delete Selected’.
	The item is moved to rejecteddata table in the database and the type field in the table has its value as ‘M’ (meaning it is manually sent to rejecteddata table and not through shefdecode). The item is removed from the scroll list displayed.
	

	118. 
	Select ‘Tabular Time Series and Graphical Time Series’ to bring up Time Series window.
	The Time Series Control window opens in Station Selection mode with the selected station highlighted. 
	

	119. 
	Select the ‘Close’ push-button on the Questionable and Bad Data window.
	The Questionable and Bad Data window closes.
	

	120. 
	From the ‘LiveData’ pull-down menu, select ‘Rejected Data Trash Can’.
	The Data Trash Can window opens. The scroll list has the rejected data displayed.
	

	121. 
	Select ‘Filter By Location’ and enter a location id.
	The scroll list has only the rejected data that is pertaining to the location id provided.
	

	122. 
	Select ‘Filter By Physical Element’ and select any physical element from the physical element scroll list.
	The scroll list has only the rejected data that is pertaining to the physical element selected.
	

	123. 
	Uncheck the ‘Location’ toggle button. Select ‘Sort By Location’.
	The scroll list has the data sorted based on location id.
	

	124. 
	Select ‘Sort By Time’.
	The scroll list has the data sorted based on observation time.
	

	125. 
	Select the ‘Reject Type’ option to be either:

‘All’

‘Auto’

‘Manual’
	The scroll list has only the data that is manually rejected using the questionable and bad data window and MB1 clicking the ‘Delete Selected’ button if the reject type option is ‘Manual’. The list will have only the data that is entered into rejecteddata table by shefdecode (automatic data) if the reject type is ‘Auto’. The list will have both the manual and auto data from the rejecteddata table if the reject type option is ‘All’.
	

	126. 
	Highlight an item in the scroll list and MB1 click Move Selected to Data Tables’.
	The selected data are moved to its respective data table and the entry is removed from rejecteddata table.
	

	127. 
	Highlight an item in the scroll list and MB1 click ‘Delete Selected’.
	The selected data is deleted from the rejecteddata table and the entry is removed from the scroll list.
	

	128. 
	MB1 click the ‘Delete All’ button.
	A confirmation window appears asking whether you want to delete all the data in the Rejected Data Trash Bin. This will delete all records from RejectedData table in the database.
	

	129. 
	Select ‘Close’ in the Data Trash Can window.
	The Data Trash Can window closes.
	

	130. 
	From the ‘LiveData’ pull-down menu, select ‘Station Reporting Status/Latest Observations’.
	The Station Reporting Status window opens, showing the station ID, the station name, when the last observation was made, and when the latest data were received. This window updates if the shef_post_latest token is set to ‘ON’ in the /awips/hydroapps/.Apps_defaults_site file.
	

	131. 
	From the ‘List’ options, select ‘All Locations With Latest Data’.
	This results in the display of all the location with their latest data information in the scroll list. 
	

	132. 
	From the ‘List’ option, select ‘Only Locations With Latest Data Older Than’.
	The ‘Hours Ago’ command line becomes active.
	

	133. 
	In the ‘Hours Ago’ command line, type ‘12 Hours’. Then press the ‘Enter’ key on the keyboard.
	All stations which have not reported in last 12 hours display. 
	

	134. 
	In the ‘Sort’ option, select ‘By Time’.
	The list is sorted by Observation Time (Z), with the most recent time at the top.
	

	135. 
	In the ‘Sort’ option, select ‘By Location’.
	The list is sorted by Location Id.
	

	136. 
	In the Station Reporting Status window, selected different stations in the top window. 
	The Latest Data for Selected Station list in the bottom of the Station Reporting Status window updates to display the latest data elements received for that station. For reference purposes, the current time field updates to show the current time. Also, information about the station’s telemetry and dcp reporting status can also be seen in the bottom of the window.
	

	137. 
	In the Station Reporting Status window, select locations without any latest data.
	The list of stations for which latest observation data is not found in the database is shown in the scroll list.
	

	138. 
	Select the ‘Close’ push-button on the Station Reporting Status window.
	The Station Reporting Status window closes.
	

	139. 
	From the ‘LiveData’ pull-down menu, select ‘Point Precipitation Accumulations’.
	The Point Precipitation Accumulations window opens.
	

	140. 
	Select the ‘Load Data’ push-button.
	Data is listed in the scrolled window based on the criteria selected.
	

	141. 
	The up and down arrow buttons are used to change the date and time to specify the end time. Change the end time using the arrows and select ‘Load Data’.
	Data is listed in the scrolled window based on the time and other criteria selected in the window.
	

	142. 
	Select ‘Filter By HSA’ button and select one or more item from the HSA scroll list and select ‘Load Data’.
	Data is listed based on the HSA selected in the scroll list and other criteria selected in the window.
	

	143. 
	Select the ‘Filter By Data Source’ button and select one or more item from the ‘PC’ or ‘PP’ scroll list. Then select ‘Load Data’.
	Data is listed based on the items selected in the scroll list and other criteria selected in the window.
	

	144. 
	Select option ‘Show Details’. Then select ‘Load Data’.
	The summary has additional information about the displayed data report in brief.
	

	145. 
	Select option ‘Add PP Reports as Needed’. Select ‘Load Data’.
	The summary shows the PP summed values which (if not selected) would otherwise be reported as MSG (missing) if there is no direct report for the mentioned duration window. The summed values are nothing but the value obtained by adding all PP reports available within that duration. Also, if the ‘Show Details’ options is selected, the reported summed PP values shows (24.0s) at the end of the line, which would have been (0.0s) meaning MSG if there is no PP report and the ‘Add PP Report As Needed’ is deselected.
	

	146. 
	Select ‘Sort By Location’. MB1 click the ‘Load’ data button.
	The report is sorted by the location id.
	

	147. 
	Select ‘Sort by Value’.
	The report is sorted by their value with the highest value in the top.
	

	148. 
	Select ‘Other’ in the duration scroll list and type a number (say 7) in the text box and select load data. (No fraction values, even if providing only the whole number before the decimal point, will be considered) 
	The report is based on the value supplied in the text box. 
If there is any other item selected in the duration scroll list (say 24) along with ‘Other’, the report will have values for both 24hr and 7 hr durations.
	

	149. 
	Select ‘By Location’ and enter a location id in the text box provided. Then select the ‘Load Data’ button.
	The report displays for the location id mentioned. The report has additional information about the individual data reported in the specified duration with their reported time, quality code etc.
	

	150. 
	Select ‘Save and Close.’
	A window for choosing the directory and file name to save the report appears. Specify the filename along with its path. The report is saved in that file.
	

	151. 
	Select ‘Print’.
	The report is printed.
	

	152. 
	Select the ‘Close’ push-button on the Point Precipitation Accumulations window.
	The Point Precipitation Accumulations window closes.
	

	153. 
	Select a station by double MB1 clicking on a station in the map. From the ‘LiveData’ pull-down menu, select ‘Station Profile’.
	The Station Profile window opens for the selected station.

The window has an elevation graph showing the river stream on which the selected station (gage) is located. It will also show other stations (gages) that are located on this stream. The graph also shows the latest observation for any of the gages located on the stream. The window has different stations that are located on this stream being listed on the station option. Upon selection of any station from this station option, the window shows its name, reach, action and flood stage information.
	

	154. 
	Select the ‘Close’ push-button on the Station Profile window.
	The Station Profile window closes.
	

	155. 
	From the ‘LiveData’ pull-down menu, select ‘River Summary’.
	The River Summary window opens. The list of streams (rivers) displays in the scroll list.
	

	156. 
	Select an item in the scroll list.
	A flood stage map displays for the selected stream. This shows the flood, stage (red), warning stage (yellow), action stage (green) for all the stations located on this stream. The graph also shows the value (blue) for the station if available.
	

	157. 
	Select different values for stage basis:

‘Max Obs/Fcst’

‘Observed’

‘Forecast’
	The value (blue) color on the graph shows the max of obs/fcst if the ‘Max Obs/Fcst’ option is selected, the observed value if the ‘Observed’ option is selected, or the forecast value if the ‘Forecast’ option is selected. The blue color does not appear if the value is not found.
	

	158. 
	Select the ‘Close’ push-button on the River Summary program.
	The River Summary program closes.
	

	159. 
	Select a station by double MB1 clicking on a station in the map. From the ‘ReferenceData’ pull-down menu, select ‘Staff Gage’.
	The Staff Gage window opens for that station. The window has a graph that shows the flood stage, action stage, warning stage, record stage, minor stage, major stage, bank full stage etc about the gage. The window also shows the name, basin, state, etc information for that station selected.
	

	160. 
	Select the ‘Close’ push-button from the bottom of the Staff Gage window.
	The Staff Gage window closes.
	

	161. 
	Select a station by double MB1 clicking on a station in the map. From the ‘ReferenceData’ pull-down menu, select ‘Impact Statement Gage’.
	The Impact Statement window opens for that station. The impact window shows the impact value, impact pe, begin date, end data, tendency of the impact in the scroll list if data is found. On selecting an item in the scroll list, the characteristics display for that statement below the scroll list. The impact also displays in the text box in the bottom of the window.
	

	162. 
	Select the ‘Cancel’ push-button from the bottom of the Impact Statement window.
	The Impact Statement window closes.
	

	163. 
	Select a station by double MB1 clicking on the station in the map. From the ‘ReferenceData’ pull-down menu, select ‘Low Water Statement’.
	The Low Water Statement window opens for that station. The window shows a list of lower and upper limits of a river physical element in the scrolled list in the top of the window. Selecting an entry in this list shows low water impact details in the information block in the lower window.
	

	164. 
	Select the ‘Close’ button on the Low Water Statement window.
	The Low Water Statement window closes.
	

	165. 
	Select a station by double MB1 clicking on a station in the map. From the ‘ReferenceData’ pull-down menu, select ‘Rating Curve’.
	The Rating Curve window opens for that station. The window shows the rating curve stage vs. flow graph. This graph is based on the shift value that is highlighted in the list box at the bottom of the screen, which has the shift value, shift data and its status (active-T inactive-F). The window shows the stage and discharge values in two different scroll lists: one with shift value applied and the other without shift value. The window also shows the flood stage and record flood stage on top of screen for the selected station.
	

	166. 
	Place the mouse at any point on the graph. Click and hold MB1 and keep moving the mouse.
	This results in showing the stage and flow (KCFS) values displayed on the top left corner of the window. The value is in correspondence to the mouse point on the map.
	

	167. 
	Select the ‘Close’ push-button from the bottom of the Rating Curve window.
	The Rating Curve window closes.
	

	168. 
	Select a station by double MB1 clicking on a station in the map. From the ‘ReferenceData’ pull-down menu, select ‘Data Sources’.
	The Data Sources window opens for that station.
	

	169. 
	Select different values for the type option:

‘Observer’

‘DCP’

‘Telemetry’
	The data pertaining to the station selected and the type selected displays. In case of the scroll lists shown, the applicable value for the station and type are highlighted.
	

	170. 
	Select the ‘Close’ push-button from the bottom of the Data Sources window.
	The Data Sources window closes.
	

	171. 
	Select a station by double MB1 clicking on a station in the map. From the ‘ReferenceData’ pull-down menu, select ‘Contacts’.
	The Contacts window opens for that station. The contact window specifies the contact information for this station display in their order of escalation (1- to be the highest in the hierarchy in person of contact list for that station) in scroll list. All the available contact information for the item that is highlighted in the scroll list is shown in the information portion of the window.
	

	172. 
	Select the ‘Close’ push-button from the bottom of the Contacts window.
	The Contacts window closes.
	

	173. 
	Select a station by double MB1 clicking on a station in the map. From the ‘ReferenceData’ pull-down menu, select ‘Crest History’.
	The Crest History window opens for that station. The window shows the stage vs. year of occurrence map.
	

	174. 
	Choose different options for filter crests by selecting the following options:

‘All’
‘Above Action Stage’
‘Below Action Stage’
	The map displayed changes accordingly and the data displayed in the right side of the window also changes appropriately.
	

	175. 
	MB1 click on an ‘X’ on the map.
	The data displayed in the right side of the window changes appropriately.
	

	176. 
	Choose different options for the sort crests by option:

‘Stage’

‘Date’

‘Flow’
	The scroll list showing stage, flow, date and time is sorted based on date if ‘Date’ is selected, stage if ‘Stage’ is selected, or flow if ‘Flow’ is selected.
	

	177. 
	Select the ‘Close’ push-button from the bottom of the Crest History window.
	The Crest History window closes.
	

	178. 
	Select a station by double MB1 clicking on a station in the map. From the ‘ReferenceData’ pull-down menu, select ‘Text Reports’.
	The E-19 Report window opens for that station.
	

	179. 
	Scroll through the various types of reports in the Report option menu and try selecting them.
	Different reports display as different report option items are selected.
	

	180. 
	With report option menu at E-19, scroll through the various values in page option menu and try selecting them. (Page option is shown only for E-19 report option.)
	Different reports display as different values selected for page option.
	

	181. 
	Select a report option value to be sorted station list.
	This shows the report of all the stations sorted based on location id.
	

	182. 
	Change the sort by option to:

‘Name’

‘County’

‘Basin’

‘Observer’
	The report of all the stations are sorted based on the location name if ‘Name’ is selected, county if ‘County’ is selected, basin if ‘Basin’ is selected, or observer name if ‘Observer’ is selected.
	

	183. 
	Select the report option value to be ‘Station Class’.
	This shows the report of all the stations detailing the station class information.
	

	184. 
	Select report option value to be ‘Service Backup’.
	This shows the report of all the stations detailing the list of stations sorted by station id.
	

	185. 
	Change the sort by option to:

‘Station’

‘WFO’

‘HSA’
	This shows the report of all the stations sorted based on the station id if ‘Station’ is selected, based on WFO if ‘WFO’ is selected, based on HSA if HSA’ is selected.
	

	186. 
	Select ‘Save’.
	A dialog showing the file name with the path displays, asking for confirmation to save. MB1 clicking the report saves the file. If cancel is selected, the dialog window closes.
	

	187. 
	Set the report option value to ‘E-19’. Select ‘Print’.

Select the contents that are needed in the printed report. Then select ‘Print’ to print the report. Select ‘Close’ to close this window.
	The report content window displays. 
The item prints.
The window closes.
	

	188. 
	Select the ‘Close’ push-button from the bottom of the Report window.
	The Report window closes.
	

	189. 
	From the ‘Product’ pull-down menu, select ‘Product Viewer’.
	The Product Viewer window opens.
	

	190. 
	From the ‘List’ option, select ‘Text Products in Database’.
	A list of products displays in the Product Information section.
	

	191. 
	If any products appear in the Product Information section, select one.
	The Product chosen display below.
	

	192. 
	Select the ‘Close’ push-button from the bottom of the Product Viewer window.
	The Product Viewer window closes.
	

	193. 
	Zoom into an area of interest by using MB2 or the ‘Zoom’ and ‘Recenter’ tools from the ‘Tools’ menu.
	The selected area of the map is enlarged and shows a greater level of detail.
	

	194. 
	MB3 click and hold on the Hydro Perspective tab and select ‘Close’.
	The Hydro Perspective closes.
	

	End of Hydroview Test

	

	Start of Point Data Control Test

	195. 
	In CAVE, Mouse Button (MB) 1 click on the Perspectives icon and select ‘Hydro’ from the dropdown menu if available. If not available, select ‘Other…’. Then select ‘Hydro’ from the Open Perspective dialog.
	The Hydro Perspective displays in CAVE.
	

	196. 
	From the ‘MapData’ pull-down menu, select ‘Point Data Control…’.
	The Point Data Control window opens and the stations display in the Hydroview main window.
	

	197. 
	In the Presets/Query Mode Frame, MB1 click on the Ad Hoc radio button
	The Ad Hoc radio button is red.
	

	198. 
	In the Elements frame, MB1 click on the first combo box and select ‘River’. *

*In the second combo box (PE), the PEs that appear are the same ones that are in the ingestfilter table. This is true for Steps 3-22. The elements that are listed in Action Steps 3-22 display in the same order in the first combo box. For example:

· River

· Rain

· Snow

· etc.


	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter (look for it in Hydrobase) table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· Primary

· HA – Reading Height

· HB – Depth below Sfc

· HC – Ceiling Height

· HD – Head Height

· HE – Regulating Gate

· HG – River Stage

· HI – Stage Trnd Indicator

· HP – Pool Elevation

· HQ – Distance to River

· HS – Spillwy Forebay El

· HT – Tailwater Elev

· QC – Runoff Volume

· QD – Canal Divers. Dsch

· QI – Inflow Discharge

· QR – River Discharge

· QT – Total Discharge
	

	199. 
	In the Elements frame, MB1 click on the first combo box and select ‘Rain’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· PC and PP

· PC   Precip Accumulator

· PP   Precip Increment

· PR   Precip Rate

· PT   Precip Type
	

	200. 
	In the Elements frame, MB1 click on the first combo box and select ‘Snow’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· SA   Areal Snowfall

· SD   Snow Depth

· SF   New Snowfall

· SR   Snow Report

· SS   Snow Density

· ST   Snow Temp at Depth

· SW   Snow Water Equiv
	

	201. 
	In the Elements frame, MB1 click on the first combo box and select ‘Temperature’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· TA   Air Temperature

· TB   Soil Temp at Depth

· TD   Dew Point Temp

· TE   Air Temp at Elev

· TM   Wet Bulb Temperature

· TP   Pan water Temp

· TS   Soil Temp at Sfc

· TV  Veg Soil Temp

· TW  Water Temperature
	

	202. 
	In the Elements frame, MB1 click on the first combo box and select ‘Agriculture’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· AD   Reserved

· AF   Sfc Frost Intensity

· AM   Sfc Dew Intensity

· AT   Time Below 25 deg F

· AU   Time Below 32 deg F

· AW   Leaf Wetness Time
	

	203. 
	In the Elements frame, MB1 click on the first combo box and select ‘Evaporation’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· EP   Evap Pan Increment

· ET   Evap Trans Total

· EV   Evap Lake Computed
	

	204. 
	In the Elements frame, MB1 click on the first combo box and select ‘FishCount’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· FS   Steelhead Fish Count
	

	205. 
	In the Elements frame, MB1 click on the first combo box and select ‘Ground’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· GD   Frost Penetr Depth

· GR   Frost Report

· GS   Ground State

· GT   Sfc Frost Thawed Dep
	

	206. 
	In the Elements frame, MB1 click on the first combo box and select ‘Ice’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· IC   Ice Cover

· IE   Extent of Ice

· IO   Extent of Open Water

· IR   Ice Report

· IT   Ice Thickness
	

	207. 
	In the Elements frame, MB1 click on the first combo box and select ‘Lake’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· LA   Lake Surface Area

· LS   Lake Storage Volume
	

	208. 
	In the Elements frame, MB1 click on the first combo box and select ‘Moisture’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· MI   Moisture Index

· MM   Wood Moisture

· MS   Soil Moisture Amount

· MT   Wood Temperature
	

	209. 
	In the Elements frame, MB1 click on the first combo box and select ‘GateDam’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· NN   Spillway Gate Number

· NO   Spec. Gate Opening
	

	210. 
	In the Elements frame, MB1 click on the first combo box and select ‘Pressure’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· PA   Atmospheric Pressure

· PD   3-hour Press Change

· PE   Press Characteristic

· PL   Sea Level Pressure
	

	211. 
	In the Elements frame, MB1 click on the first combo box and select ‘Radiation’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· RI   Incoming Radiation

· RP   Possible Radiation

· RT   Total Radiation Time

· RW   Totl Solar Radiation
	

	212. 
	In the Elements frame, MB1 click on the first combo box and select ‘Weather’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· XC   Total Sky Cover

· XP   Past Weather

· XR   Relative Humidity

· XV   Visibility

· XW   Present Weather
	

	213. 
	In the Elements frame, MB1 click on the first combo box and select ‘Wind’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· UC   Accumulated Wind

· UD   Wind Direction

· UG   Wind Gust Speed

· UL   Wind Travel Length

· UP   Peak Wind Speed

· UQ   Wind Direct & Speed

· UR   Wind Dir at Peak Spd

· US   Wind Speed
	

	214. 
	In the Elements frame, MB1 click on the first combo box and select ‘Power’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· VB   Battery Voltage

· VE   Energy Gener Total
	

	215. 
	In the Elements frame, MB1 click on the first combo box and select ‘WaterQuality’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· WV   Water Velocity
	

	216. 
	In the Elements frame, MB1 click on the first combo box and select ‘YUnique’.
	In the Elements frame, the PEs that appear in the second combo box (PE) depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· YA   15m Per Above Stage

· YC   Random Rep Seq Num

· YF   Forward Power

· YG

· YH

· YI

· YJ
	

	217. 
	If the shef_procobs token value in the .Apps_defaults_site file is set to OFF, the first combo box in the Elements frame will have an option called ‘Processed’.

If the token value is set to ‘ON’, the first combo box will not have an option called ‘Processed’.
	If the token value of shef_procobs is set to ‘OFF’, the PEs that appear in the second combo box (PE) in the Elements frame depend on what PE’s are in the ingestfilter table with a value of ‘T’ for the ingest column.

Some of the common PEs are:

· IR   Ice Report

· PP   Precip Increment

· QR   River Discharge

· SI   Snow Depth on Ice

· TA   Air Temperature
	

	218. 
	In the Value/Time frame, MB1 click on the up and down arrow of the first set of arrows on the left side.
	When the up arrow is clicked, the day is increased. For example, 2006-01-22 18:00 changes to 2006-01-23 18:00. 
When the down arrow is clicked, the day is decreased. For example, 2006-01-23 18:00 changes to 2006-01-22 18:00.
	

	219. 
	In the Value/Time frame, MB1 click on the up and down arrow of the second set of arrows on the right side.
	When the up arrow is clicked, the hour is increased. For example, 2006-01-22 18:00 changes to 2006-01-22 19:00. 
When the down arrow is clicked, the hour is decreased. For example, 2006-01-22 19:00 changes to 2006-01-22 18:00.
	

	220. 
	In the Value/Time frame, MB1 click on the ‘Value Is’ combo box.
	In the Value Is combo box, the default value is Latest Value. The following options are also available:

· Latest Value

· Value for Selected Time

· Min Value in Window

· Max Value in Window

· Value Change in Window
	

	221. 
	In the Elements frame, select ‘Temperature’ in the first combo box on the left.

In the Elements frame, select ‘TA Air Temperature’ in the second combo box on the right.

In the Filtering frame, MB1 click on the check box next to the button labeled ‘Type/Source’.
	When the check box next to the ‘Type/Source’ button is checked, data values display in the Hydroview GUI displaying temperature data.
	

	222. 
	In the Filtering frame, MB1 click on the ‘Type/Source’ button.
	When the ‘Type/Source’ button is clicked, a window appears displaying type sources. The list of type sources come from the ingestfilter table. Some of the common Type/Sources for Temperature are:

· RG    GOES

· RZ     Nonspecific Observed
	

	223. 
	In the Type/Source popup window, MB1 click on ‘RG GOES’, if available. (If not available, then select any single type/source.)  MB1 click on ‘Apply’.

Then MB1 click on the ‘Close’ button.


	If ‘RG’ was selected, any values that have a type/source of ‘RZ’ disappear. Some of the values displayed in the Hydroview GUI disappear. This occurs if there are some values displayed that have a Type/Source of ‘RZ’.

If a different type/source was selected, any values that do not have that particular type/source disappear from the GUI

When the ‘Close’ button is clicked, the Type/Source popup window closes.
	

	224. 
	In the Filtering frame, enable the checkbox next to the ‘Service Area…’ button.

MB1 click on the ‘Service Area…’ button.

Select the first HSA and make sure all of the other HSAs are unselected.

MB1 click ‘Apply’.

Then MB1 click the ‘Close’ button.
	When the checkbox is checked, some values displayed disappear from the GUI.

When the ‘Service Area…’ button is clicked, a window appears displaying a list of HSAs.

When the first HSA is selected and the ‘Apply’ button is clicked, the values displayed on the map are for stations whose HSA is the same as the HSA the user selected in the popup window. 
When the ‘Close’ button is clicked, the Service Area popup window closes.
	

	225. 
	In the Filtering frame, enable the checkbox next to the ‘Data Source…’ button.

MB1 click on the ‘Data Source…’ button.

Select two of the options which appear in the popup window (Observer and DCP) and MB1 click ‘Apply’.

Then MB1 click the ‘Close’ button.
	When the checkbox is checked, all of the values displayed disappear from the GUI.

When the ‘Data Source…’ button is clicked, a new window appears displaying a list of telem types. This list includes all of the telem types from the telmtypes table and as well as ‘Observer’, ‘DCP’ and ‘undefined’.

When the first two options (‘Observer’ and ‘DCP’) are selected and the ‘Apply’ button is clicked, some of the values display on the GUI. The values that display have a telem_type value of ‘Observer’ or ‘DCP’ in the stnclass table.

When the ‘Close’ button is clicked, the ‘Data Source…’ popup window closes.
	

	226. 
	In the Elements frame, MB1 click on the left combo box and select ‘River’. At the bottom of the GUI, MB1 click on the ‘Map’ button.
	When ‘River’ is selected in the left combo box in the Elements frame, the right combo box in the Elements frame is set to ‘Primary’. When the ‘Map’ button is clicked, the GUI updates with river data for all the stations not filtered out.
	

	227. 
	In the Display frame, check the box labeled ‘Color River Icons:’.
	The icons in the display change to 1 of 5 colors:

· Light green – river stage/flow for the station is below the action/flood levels

· Yellow – river stage/flow for the station is at or above the action level but below the flood level

· Red – river stage/flow for the station is at or above the flood level

· Gray – stage/flow data could not be retrieved for the station

· Dark green – the station has a value but the action/flood stage data are not available in the RiverStatus table.
	

	228. 
	In the Display frame, MB1 click on the ‘River Color/Value Based On:’ combo box and select ‘Observed Value’.
	The values that display in the GUI are the observed values for each station for that particular date/time.
	

	229. 
	In the Display frame, MB1 click on the ‘River Color/Value Based On:’ combo box and select ‘Forecast Value’.
	The values that display in the GUI are the largest forecast values for each station for each station for that particular date/time.
	

	230. 
	In the Display frame, MB1 click on the ‘River Color/Value Based On:’ combo box and select ‘Max (Obs, Fcst)’.
	The value that displays in the GUI for each station is the maximum of the forecast or the observed value.
	

	231. 
	In the Display frame, MB1 click on the ‘Display Values As:’ combo box and select ‘Raw Value’.
	The value that displays in the GUI for each station is just the raw data value which comes from the database.
	

	232. 
	In the Display frame, MB1 click on the ‘Display Values As:’ combo box and select ‘Raw Value/Flood Level’.
	The values that display in the GUI for each station are the raw data values and the flood stage. The flood stage/level is the value of the fs field which is located in the Riverstat table. If a flood stage/level is not defined for a station, an ‘M’ displays above the raw data value. The flood stage/level value displays above the raw data value.
	

	233. 
	In the Display frame, MB1 click on the ‘Display Values As:’ combo box and select ‘Raw Value/Stage Flow’.
	The values that display in the GUI for each station are the raw data values and a derived stage or flow value. The derived value is a flow if the raw value is a stage and vice versa. If a derived value is not defined for a station, an ‘M’ displays above the raw data value. The derived value displays above the raw data value. 
	

	234. 
	In the Display frame, MB1 click on the ‘Display Values As:’ combo box and select ‘Flood Depart’.
	If the value is not missing, the value that displays in the GUI for each station is the current stage value minus the flood stage value. This value is the Flood Stage departure. If a flood stage is not defined for a particular station, then the station data is missing.
	

	235. 
	In the Display frame, MB1 click on the ‘Display Values As:’ combo box and select ‘Flood Depart/Level’.
	The values that display in the GUI for each station are the flood stage departure and the flood stage/level. The flood stage/level displays on top of the flood depart value. If a flood stage/level is not defined for a particular station, then the station data is missing.
	

	236. 
	In the Display frame, MB1 click on the ‘Display Values As:’ combo box and select ‘Raw Value’.

MB1 click on the ‘Tabulate’ button.
	The Point Data Tabular Display appears showing all the stations not filtered out and the values that are currently displayed in the GUI.
	

	237. 
	In the Point Data Tabular Display window, MB1 click on the first station listed that has non-missing data. 

MB1 click on the ‘Time Series Graph’ button and select ‘Graph’ button.

Close the Time Series Display and Control.
	When the ‘Time Series Graph’ button is clicked, the Time Series loads.

The time series for the selected station displays in a graphical format. 

	

	238. 
	In the Point Data Tabular Display window, MB1 click on the ‘Time Series Table’ button.

Close the Time Series Tabular Time Series and Control.
	When the Time Series Table button is clicked, Time Series loads.

The time series for the selected station displays in a tabular format.
	

	239. 
	In the Point Data Tabular Display window, MB1 click on the ‘Print’ button.


	The data displayed in the table prints.
	

	240. 
	In the Point Data Tabular Display window, MB1 click on the ‘Save’ button.

Enter ‘test_save.pdc’ in the ‘Selection’ textbox.

MB1 click the ‘OK’ button.
	When the ‘Save’ button is clicked, a dialog window appears allowing the user to specify a location and filename. 
When the ‘OK’ button is clicked, the report is saved to the file “test_save.pdc” in the specified save directory (awips/hydroapps/whfs/local/data/report).

The report contains data that is identical to the data displayed in the Point Data Tabular Display window.
	

	241. 
	In the Point Data Tabular Display window, MB1 click on the ‘Close’ button.
	The Point Data Tabular Display window closes and control is returned to the Point Data Control GUI.
	

	242. 
	In the Point Data Control GUI, MB1 click on the ‘Unmap’ button.


	When the ‘Unmap’ button is clicked, all of the values displayed in the Hydroview GUI are removed (unmapped).
	

	243. 
	In the Point Data Control GUI, MB1 click on the ‘Map’ button.
	When the ‘Map’ button is clicked, all of the station values that are currently not filtered out are mapped to the Hydroview GUI. The stations and data displayed are the same ones that were displayed during Step 48.
	

	244. 
	In the Point Data Control window, MB1 click on the ‘Close’ button.
	The Point Data Control window closes.


	

	245. 
	MB3 click and hold on the Hydroview Perspective tab and select ‘Close’.
	The Hydroview Perspective closes.
	

	246. Test – Time Step Mode

	247. 
	In CAVE, MB1 click on the Perspectives icon and select ‘Hydro’ from the dropdown menu if available. If not available, select ‘Other…’. Then select ‘Hydro’ from the Open Perspective dialog.
	The Hydro Perspective displays in CAVE.
	

	248. 
	From the ‘MapData’ pull-down menu, select ‘Point Data Control…’.
	The Point Data Control window opens and the stations display in the Hydroview main window.
	

	249. 
	In the Presets/Query Mode Frame, MB1 click on the ‘Time-Step’ radio button.
	The ‘Time Step’ radio button is filled in. The GUI changes in the ‘Elements’, ‘Value/Time’, ‘Filtering’ and ‘Display’ sections.
	

	250. 
	In the Elements frame, MB1 click on the first combo box, the ‘Element Type Combo Box’. 
	The available selections listed are:

‘River’, ‘Rain’, ‘Snow’, ‘Temperature’, ‘Humidity’ and ‘Wind’. 
	

	251. 
	In the Elements First Combo Box, select ‘River’. 
	The selected element in the Elements Second Combo Box is ‘STAGE/POOL’.
	

	252. 
	MB1 click on the ‘Elements Second Combo Box’ (right one).
	The available selections listed are:

‘STAGE/POOL’, ‘FLOW/STORAGE’, ‘DEPTH ABOVE FLOOD STAGE’ and ‘PERCENT OF FLOOD FLOW’.
	

	253. 
	In the Elements frame, MB1 click on the ‘Element Type Combo Box’ (left one) and select ‘Rain’.
	The selected element in the Element Combo Box is ‘INSTANTANEOUS’.
	

	254. 
	MB1 click on the ‘Element Combo Box’ (right one).
	The available selections listed are:

‘INSTANTANEOUS’, ‘1-HOUR PRECIP TOTAL’, ‘3-HOUR PRECIP TOTAL’, ‘6-HOUR PRECIP TOTAL’ and ‘24-HOUR TOTAL (12Z)’.
	

	255. 
	In the Elements frame, MB1 click on the ‘Element Type Combo Box’ and select ‘Snow’.
	The selected element in the Element Combo Box is ‘SNOW WATER EQUIV’.
	

	256. 
	MB1 click on the ‘Element Combo Box’ (right one).
	The available selections listed are:

‘SNOW WATER EQUIV’ and ‘SWE – 24 HOUR CHANGE’.
	

	257. 
	In the Elements frame, MB1 click on the ‘Element Type Combo Box’ and select ‘Temperature’.
	The selected element in the Element Combo Box is ‘TEMPERATURE’.
	

	258. 
	MB1 click on the ‘Element Combo Box’ (right one).
	The available selections listed are:

‘TEMPERATURE’, ‘TEMP. 24 HOUR CHANGE’, ‘MAX TEMP’ and ‘MIN TEMP’.
	

	259. 
	In the Elements frame, MB1 click on the ‘Element Type Combo Box’ and select ‘Humidity’.
	The selected element in the Element Combo Box is ‘DEWPOINT’.
	

	260. 
	MB1 click on the ‘Element Combo Box’ (right one).
	The available selections listed are:

‘DEWPOINT’, ‘DEWPT - 24 HR CHANGE’ and ‘RELATIVE HUMIDITY’.
	

	261. 
	In the Elements frame, MB1 click on the ‘Element Type Combo Box’ and select ‘Wind’.
	The selected element in the Element Combo Box is ‘WIND SPEED’.
	

	262. 
	MB1 click on the ‘Element Combo Box’ (right one).
	The available selections listed are:

‘WIND SPEED’ and ‘WIND DIRECTION’.
	

	263. 
	In the Value/Time frame, MB1 click on the up and down arrow of the first set of arrows on the left side.
	When the up arrow is clicked, the day is increased. For example, 2006-01-22 18:00 changes to 2006-01-23 18:00. 
When the down arrow is clicked, the day is decreased. For example, 2006-01-23 18:00 changes to 2006-01-22 18:00.

The data displayed on the Map changes.
	

	264. 
	In the Value/Time frame, MB1 click on the up and down arrow of the second set of arrows on the right side.
	When the up arrow is clicked, the hour is increased. For example, 2006-01-22 18:00 changes to 2006-01-22 19:00. 
When the down arrow is clicked, the hour is decreased. For example, 2006-01-22 19:00 changes to 2006-01-22 18:00.

The data displayed on the Map changes.
	

	265. 
	In the Elements section, choose the ‘Temperature’ element type.

In the Filtering frame, make sure the ‘Type/Source’ check box is checked.

MB1 click on the ‘Type/Source…’ button.
	When the ‘Type/Source’ button is clicked, a window appears displaying type sources. The list of type sources come from the ingestfilter table. Some of the common Type/Sources for Temperature are:

· GOES - RG

· LARC – RP

· SNOTEL – RM

· ALERT – RR

· METAR - RZ
	

	266. 
	In the Type/Source popup window, MB1 click on ‘GOES – RG’. Then MB1 click on ‘Apply’.


	If ‘RG’ was selected, any values that have a type/source of ‘RZ’ disappear. (Verify by turning on the Display Section’s Param Code button.)  Some of the values displayed in the Hydroview GUI disappear. This occurs if there are some values displayed that have a Type/Source of ‘RZ’.
	

	267. 
	MB1 click the ‘Close’ button in the Type/Source dialog.
	The Type/Source dialog closes.


	

	268. 
	In the Filtering frame, enable the checkbox next to the ‘Service Area…’ button.

MB1 click on the ‘Service Area…’ button.

Select the first HSA and make sure all of the other HSAs are unselected.

MB1 click on ‘Apply’.
	If the associated checkbox is checked, some values displayed disappear from the GUI.

When the ‘Service Area…’ button is clicked, a window appears displaying a list of HSAs.

When the first HSA is selected and the ‘Apply’ button is clicked, the values displayed on the map is for stations whose HSA is the same as the HSA the user selected in the popup window. 
	

	269. 
	MB1 click ‘Close’ in the Service Area dialog.
	The Service Area dialog closes.
	

	270. 
	In the Elements section, select the ‘RIVER’ Element Type.
	In the Filtering Section, there appears a ‘Stations:’ option menu with ‘All’ as the default.
	

	271. 
	In the Filtering Section, deselect all Type/Source and Service Area checkboxes (to make sure that stations are not unnecessarily being filtered out).

In the Display Section, check the ‘Icon’ checkbox.

Choose the ‘Stream’ option under the ‘Stations’ option in the Filtering section.
	Only plain stream locations display. Triangles with NO rectangles are plain stream locations.
	

	272. 
	In the Filtering Section, select the ‘Reservoir’ option.
	Only standard reservoir locations display. Triangles with rectangles under them represent reservoirs.
	

	273. Test - Common Filter and Display Options Procedure

	274. 
	In the Filtering frame, uncheck the ‘Show NonFcstPts’ checkbox.
	Only Forecast points display. A station is a forecast point if the station’s entry in the StnClass table has the character F in its disp_class field. A forecast point has a circle on top of the triangle.
	

	275. 
	Check the ‘Show NonFcstPts’ checkbox.
	All points that were filtered out from the previous steps are displayed.
	

	276. 
	In the Filtering frame, uncheck the ‘Show Missing’ checkbox.
	Only stations with non-missing values display in the GUI.
	

	277. 
	Check the ‘Show Missing’ checkbox.
	Stations with missing values display in the GUI (with ‘M’ for the value if that displays).
	

	278. 
	In the Filtering frame, enter ‘25’ in the textbox next to the ‘Value’ combo box.

MB1 click on the ‘Value’ combo box and select ‘Value >=’.
MB1 click on the ‘Value’ combo box and select ‘Value <=’.

In the Filtering frame, MB1 click on the ‘Value’ combo box and select ‘Any Value’.
	When the ‘Show Pts With:’ combo box is set to ‘Value >=’, any value that is greater than or equal to 25 displays in the GUI.

When the ‘Value’ combo box is set to ‘Value <=’, any value that is less than or equal to 25 displays in the GUI.

When the ‘Value’ combo box is set to ‘Any Value’, all data values that are not filtered out display again in the GUI.
	

	279. 
	Enter ‘100’ in the textbox next to the ‘Elev’ combo box.

MB1 click on the’ Elev’ combo box and select ‘Elev >=’.

MB1 click on the ‘Elev’ combo box and select ‘Elev <=’.

MB1 click on the ‘Elev’ combo box and select ‘Any Elev’.
	When the ‘Elev’ combo box is set to ‘Elev >=’, any station that has an elevation greater than or equal to 100 display in the GUI.

When the ‘Elev’ combo box is set to ‘Elev <=’, any station that has an elevation less than or equal to 100 display in the GUI.

When the ‘Elev’ combo box is set to ‘Any Elev’, all data values that are not filtered out display again in the GUI.
	

	280. 
	In the Display frame, check and uncheck the following buttons.

‘Value, Id, Name, Icon Name’

‘Time, Elevation, Param Code’
	When a box for a data element is checked, that data element display on the map.

A maximum of one of ‘Time’, ‘Elevation’, or ‘Param Code’ can be selected at a time. The rest of the buttons can be selected in any combination.
	

	281. 
	MB1 click on the ‘Tabulate’ button.
	The Point Data Tabular Display appears showing all the stations not filtered out and the values that are currently displayed in the GUI.
	

	282. 
	In the Point Data Tabular Display window, MB1 click on the stations that have non-missing values. 

MB1 click on the ‘Time Series Graph’ button.

Close the Time Series Display window.
	When the ‘Time Series Graph’ button is clicked, the Time Series loads. The time series for the selected station displays in a graphical format.
	

	283. 
	In the Point Data Tabular Display window, MB1 click on the ‘Print’ button.
	The data displayed in the table prints.
	

	284. 
	In the Point Data Tabular Display window, MB1 click on the ‘Save’ button.

Enter ‘test_save.pdc’ in the ‘Selection’ textbox.

MB1 click on ‘OK’.
	When the ‘Save’ button is clicked, a dialog window appears allowing the user to specify a location and filename. 
When the ‘OK’ button is clicked, the report is saved to the file ‘test_save.pdc’ in the specified save directory (awips/hydroapps/whfs/local/data/report).

The report contains data that is identical to the data displayed in the Point Data Tabular Display window.
	

	285. 
	In the Point Data Tabular Display window, MB1 click on the ‘Close’ button.
	The Point Data Tabular Display window closes and control is returned to the Point Data Control GUI.
	

	286. 
	In the Point Data Control GUI, MB1 click on the ‘Unmap’ button.
	When the ‘Unmap’ button is clicked, all of the values displayed in the Hydroview GUI are removed (unmapped).
	

	287. 
	In the Point Data Control GUI, MB1 click on the ‘Map’ button.
	When the ‘Map’ button is clicked, all of the station values that are currently not filtered out are mapped to the Hydroview GUI.
	

	288. 
	Set the following options. Apply and close filter dialogs as needed.

· In the Presets/Query Mode frame, the ‘Query Mode’ is set to ‘Ad Hoc’.

· In the Elements frame, the ‘Element Type’ (left) combo box is set to ‘River’.

· In the Elements frame, the ‘Element’ (right) combo box is set to ‘Primary’.

· In the Value/Time frame, the ‘Value Filters’ combo box is set to ‘Latest Value’.

· In the Filtering frame, the ‘Type/Source’ button is unchecked.

· In the Filtering frame, the ‘Service Area…’ checkbox is checked.

· Select the first HSA.

· In the Filtering frame, the ‘Data Source…’ checkbox is checked. 

· In the ‘Data Source…’, the dialog box is set to select ‘Observer Only’.

· In the Filtering frame, the ‘Show NonFcstPts’ checkbox is checked.

· In the Filtering frame, the ‘Show Missing’ checkbox is unchecked.

· In the Filtering frame, the two Show Pts with combo boxes are set to ‘Any Value’ and ‘Any Elev’. The corresponding text boxes are desensitized.

· In the Display frame, the ‘Value’, ‘ID’ and ‘Icon’ checkboxes are checked.
	
	

	289. 
	Continued from step 92:

Set the following options. Apply and close filter dialogs as needed.

· The ‘Name’ checkbox is unchecked.

· In the Display frame, the ‘Time’ and ‘Elevationand Param Code’ radio buttons are unchecked.

· In the Display frame, the ‘Color River Icons’ checkbox are checked.

· In the Display frame, the ‘River Color/Value Based On:’ combo box is set to ‘Max(Obs, Fcst)’

· In the Display frame, the ‘Display Values As:’ combo box is set to ‘Raw Value’.

· In the Point Data Control GUI, MB1 click on the ‘Save…’ button.
	The Save Present Options dialog appears.
	

	290. 
	Enter ‘test_set’ in the ‘UniqueId:’ textbox under the New Information section.

Enter ‘test option set’ in the ‘Description:’ textbox.

Enter ‘2’ in the ‘Rank:’ textbox.

MB1 click on the ‘Ok’ button.
	When the ‘Ok’ button is clicked, the Save Preset Options dialog box closes and the option set is saved to the pointdatapresets table in the IHFS database.
	

	291. 
	In the Point Data Control window, MB1 click on the ‘Close’ button.

MB3 click and hold on the Hydroview tab. Select ‘Close’.
	The Point Data Control GUI and Hydroview Perspective close.


	

	292. 
	MB1 click on the Perspectives icon and select ‘Hydro’ from the dropdown menu if available. If not available, select ‘Other…’. Then select ‘Hydro’ from the Open Perspective dialog.
	The Hydro Perspective displays in CAVE.
	

	293. 
	From the ‘MapData’ pull-down menu, select ‘Point Data Control…’.
	The Point Data Control window opens and the stations display in the Hydroview main window.
	

	294. 
	In the Presets/Query Mode frame, change the value of the ‘Selected Preset:’ combo box to ‘test option set’.
	When ‘test option set’ is selected in the ‘Selected Preset:’ combo box, all of the following is set in the GUI:

· In the Presets/Query Mode frame, the ‘Selected Preset:’ combo box displays ‘test option set’.

· The other settings are the same as mentioned in Action Steps 92 and 93.
	

	295. 
	In the Presets/Query mode frame, MB1 click on the ‘Delete’ button.
	When the ‘Delete’ button is clicked, the preset is deleted and removed from the pointdatapresets table upon the relaunch of Hydroview.
	

	296. 
	In the Point Data Control window, MB1 click on the ‘Close’ button.
	When the ‘Close’ button is clicked, the Point Data Control GUI closes.
	

	297. 
	Exit the Hydroview Perspective.
	The Hydroview Perspective closes.
	

	End of Point Data Control Test
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