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Test Case Description

This test case demonstrates functionality contained in the Options and Tools menus, specifically Set Time, Distance Bearing, Distance Speed, Home, VR-Shear, and Put home cursor, and more.

· Requirements:

· Not Applicable.

· Data Input:

· Not Applicable.

· Prerequisite Conditions: 

1. The tester must be logged on to a graphics workstation (LX) with valid username & password.

2. The PX apps must not be failed over, or the LAPS section(s) can not be executed.

3. LAPS and WarnGen sections cannot be executed on an RFC (TBDR).

4. On TBW4 (AK), scales are different: for example, when the step says CONUS, usually State is the equivalent scale.

	Step #
	Action / Inputs
	Expected Outputs
	Pass(P)/

Fail(F)

Pending (Pen)
	DR #, Name, Description for failed step 
	Special Needs / Comments

	1. 
	Left click on the desk top and select Start D2D from the list.
	The D2D system launches
	
	
	

	2. 
	From the Scale pull-down menu (left side of toolbar), select WFO.  

(Note: on tbw4, select State.)
	Main pane map scale changes to selected scale.
	
	
	

	3. 
	Open the Tools menu from the D2D menu bar.  Click on the dashed lines at the top of the menu to tear the menu off.


	The Tools menu appears.
	
	
	

	4. 
	Select Az/Ran Overlay.
	The azimuth/range radar map overlay displays
	
	
	

	5. 
	Move the Az/Ran Overlay by clicking and releasing MB3.
	The Az/Ran Overlay moves to where the cursor was released.
	
	
	

	6. 
	Select clear on D2D.
	Main pane clears the Az/Ran Overlay.
	
	
	

	7. 
	Under the Tools menu, select baselines.
	Lines are loaded onto the main pane.  Each vertex (endpoint) is names with a letter X or X’, where X is some letter between A-J.
	
	
	

	8. 
	Observe the baselines and choose one to move.  Move the entire baseline: move the mouse over the center of the line, with MB1 click, hold, move the mouse, and let go at the desired location.  


	Line moves to desired location.  
	
	
	

	9. 
	Move a vertex (endpoint): move the mouse over a vertex, with MB1 click, hold, move the mouse, and let go at the desired location.  


	Vertex moves to desired location.  
	
	
	

	10. 
	Add a vertex: move the mouse over the baseline, click and hold MB3, and select Add Vertex.  Move mouse to the desired location and click  MB1.
	Menu appears. A third vertex is added to the baseline.
	
	
	

	11. 
	Select clear on D2D.
	Main pane clears the baselines.
	
	
	

	12. 
	From the Tools menu, select Distance Bearing.
	Five lines are displayed on the main pane, with each line having an unlabeled end and a labeled end.  The azimuth and range of the labeled end relative to the unlabeled end appear with each line.
	
	
	

	13. 
	Click MB2 on Distance Bearing in the product legend.
	Distance Bearing is now editable.
	
	
	

	14. 
	Move the cursor to a position over one of the lines.
	The cursor changes to a cross-hair shape.
	
	
	

	15. 
	Press and hold MB1 on the line.  Move it to a new location.
	Line is moved.
	
	
	

	16. 
	Move the cursor to the labeled end of the line.
	The cursor changes from NW-pointing to NE-pointing when moved over the endpoint.
	
	
	

	17. 
	Press and hold MB1 over the endpoint to shorten, lengthen, and change the orientation of the line.
	Line length is altered and label values change.
	
	
	

	18. 
	From the Satellite menu, select IR Window.
	Satellite data is displayed.
	
	
	

	19. 
	Drag the labeled endpoint to a position over the nearest cloudy area on the satellite image.
	The range and azimuth of the cloudy area relative to the location of the unlabeled endpoint appear.
	
	
	

	20. 
	Select clear on D2D.
	Main pane clears the baselines.
	
	
	

	21. 
	From the Scale pull-down menu (left side of toolbar), select CONUS (State on TBW4).
	Main pane map scale changes to selected scale.
	
	
	

	22. 
	From the Satellite menu select IR Window.
	Infrared Satellite image is displayed on the main pane.
	
	
	

	23. 
	From the D2D Tools menu, select Distance Speed.
	A storm centroid labeled “Drag me to feature” is displayed in the large pane, and a Distance Speed window opens.
	
	
	

	24. 
	Select the last frame of the loop by selecting the >>| button (this displays the most current image).


	Last frame is displayed, which usually displays by default.
	
	
	

	25. 
	Press and hold MB1 over the centroid, and move the centroid to any significant area of cloudiness.


	The storm track and time annotations are displayed.


	
	
	

	26. 
	Select the first frame of the loop by clicking the |<< button. 


	First frame (oldest image) is displayed.
	
	
	

	27. 
	Move the centroid to the location of the cloudiness that was selected in Step 26.  Note that the area of cloudiness likely will have moved.
	The storm track and time annotations change accordingly.


	
	
	

	28. 
	Select Loop to animate the images.
	The storm centroid follows the storm track and time annotations, which follow the approximate movement of the area of cloudiness.
	
	
	

	29. 
	Select the Time and Polyline radio buttons from the Distance Speed window.
	The parameters are changed on the display.


	
	
	

	30. 
	Clear the large pane.


	Graphics and tools are cleared from the main pane.
	
	
	

	31. 
	From the Scale pull-down menu (left side of toolbar), select CONUS (State on TBW4).
	Main pane map scale changes to selected scale.
	
	
	

	32. 
	Under Satellite, select IR Window.
	Infrared Satellite image is displayed on the main pane.
	
	
	

	33. 
	From the D2D Tools menu, select Time of Arrival / Lead Time.  This is very similar to the Distance Speed.
	A storm centroid labeled “Drag me to feature” is displayed in the large pane, and a Distance Speed window opens.  A solid centroid is also displayed.
	
	
	

	34. 
	Select the last frame of the loop by selecting the [>>|]  button (to display the most current image, usually is default).
	Last frame is displayed.
	
	
	

	35. 
	Press and hold MB1 over the centroid, and move the centroid to any significant area of cloudiness.


	The storm track and time annotations are displayed.


	
	
	

	36. 
	Select the first frame of the loop by clicking the |<< button.


	First frame (oldest image) is displayed.
	
	
	

	37. 
	Move the centroid to the location of the cloudiness that was selected in Step 36.  Note that the area of cloudiness likely will have moved.
	The storm track and time annotations change accordingly.


	
	
	

	38. 
	Select Loop to animate the images.
	The storm centroid follows the storm track and time annotations, which follow the approximate movement of the area of cloudiness.
	
	
	

	39. 
	Select the last frame of the loop by selecting the >>| button (this displays the most current image).


	Animation stops and last frame (newest frame) is displayed, which usually displays by default.
	
	
	

	40. 
	Move the solid centroid (it is not attached to the storm track) to some location ahead of the storm track by dragging with MB1.
	The time listed with the solid centroid (lead time) increases.
	
	
	

	41. 
	Click on Polyline and move the polylines around.  Then move the centroid within the boundaries of the Polyline.
	Confirm that there is a value showing on the centroid when moving within the polylines.


	
	
	

	42. 
	Now move the centroid outside the boundaries of the Polyline.
	Confirm that the centroid does not come back with a value when maneuvering outside the polylines.
	
	
	

	43. 
	Click on Circular Polyline and move the polylines around.  Then move the centroid within the boundaries of the Polyline.
	Confirm that there is a value showing on the centroid when moving within the circular polylines.


	
	
	

	44. 
	Now move the centroid outside the boundaries of the Circular Polyline.
	Confirm that the centroid does not come back with a value when maneuvering outside the circular polylines.
	
	
	

	45. 
	Clear the main pane.
	Main pane cleared.
	
	
	

	46. 
	Set the scale to State(s).


	The scale is set to State(s).
	
	
	

	47. 
	Select a radar or satellite product you want to track.
	The desired product is loaded.
	
	
	

	48. 
	From the Tools menu, select Distance Speed. Observe that the Distance Speed dialog is loaded and the Drag me to feature locater is displayed. 


Zoom in to the feature to be tracked.


Move the Drag me to feature locater to the feature to be tracked.
	The Distance Speed tool is loaded and the Drag me to feature is displayed on the product.

The locater is placed on the feature.
	
	
	

	49. 
	From the Tools menu, select Feature Following Zoom.

Enable looping.

Observe that while the product animates, the map background is moving as well.
	Feature Following Zoom is selected.

Looping is enabled.

While looping the product, note that the feature remains in view.
	
	
	

	50. 
	Clear the large pane.


	Graphics and tools are cleared from the main pane.
	
	
	

	51. 
	From the Scale pull-down menu (left side of toolbar), select WFO.  

(Note: on tbw4, select State.)
	Main pane map scale changes to selected scale.
	
	
	

	52. 
	From the Tools menu, select Home.
	An X with the word Home is displayed on the screen.
	
	
	

	53. 
	Over Home Location in the product legend click MB2.


	The Home Location is editable.
	
	
	

	54. 
	Press and hold MB1 over the Home marker to change its location.  Move the cursor to another part of the screen, and release MB1.
	Home is moved.
	
	
	

	55. 
	Press and hold MB1 to sample the image at a location away from the Home marker.
	The range and azimuth of the cursor location relative to the Home marker appear.
	
	
	

	56. 
	Clear the large pane.
	Graphics and tools are cleared from the main pane.
	
	
	

	57. 
	From the D2D kxxx radar menu, load an 8-bit SRM or 8-bit Velocity or any combination product that includes either.
	The radar product loads.
	
	
	

	58. 
	From the D2D Tools menu, select Estimated Actual Velocity.  
	The Estimated Actual Velocity tool loads.  Note the following:
Product Legend: Estimated Act Vel (Editable)
Readout: The EAV (degrees from and the speed in knots) at each end of the segment on the display.
	
	
	

	59. 
	Move the end of the EAV line segment so that the endpoints are over valid data. Verify that the results are reasonable. If displayed over an 8-bit SRM the EAV readout is the absolute velocity. 

The readout is valid for the pixel under each end point. The readout shows the EAV (degrees from and the speed in knots) at each end of the segment on the display. The angle of the segment provides a bidirectional vector that is used to compute the full velocity; whether the velocities are out-bound or in-bound determines which of the two directions the vector wind is from.

Repeat moving the segment and the segment endpoints. Make sure to test extreme segment lengths and positions.
	The EAV result is reasonable.  
	
	
	

	60. 
	Clear the large pane.
	Graphics and tools are cleared from the main pane.
	
	
	

	61. 
	From the Tools menu, select LAPS tools.  Acknowledge any error dialogs and continue.  Note that Steps 52 through 56 may only be performed if both PX swap packages are in their primary configuration.
	The Local Analysis and Prediction System Tools window appears. 

Note: LAPS is not available for OCONUS sites – on TBW4 skip to step 54.
	
	
	

	62. 
	Select Configure Analysis Domain  from the Tools menu in the Local Analysis and Prediction System Tools window.
	The Configure Analysis Domain tool opens.
	
	
	

	63. 
	Click the Load button under LAPS Relocator.


	The LAPS Relocator boxes and center point appear on the D2D.
	
	
	

	64. 
	Move the center point, but keep it within the small box.  Select Apply  under LAPS Relocator and then click the Localize LAPS button.
	A Confirmation window opens.
	
	
	

	65. 
	Select Yes in the Confirmation window.
	The LAPS domain is relocalized.  After the next LAPS run, the LAPS Domain will display in the new position.  

(If there will be a long wait for the next update, continue on and come back to this series of steps later.)
	
	
	

	66. 
	Clear the large pane.
	Graphics and tools are cleared from the main pane.
	
	
	

	67. 
	From the Scale pull-down menu (left side of toolbar), select Regional.  

(Note: on tbw4, select State.)
	Main pane map scale changes to selected scale.
	
	
	

	68. 
	From the Tools menu, select Points.
	Ten points (A-J) are loaded onto the main pane.
	
	
	

	69. 
	Move a point: move the mouse over a point, click and hold with MB1, drag the mouse, and let go of MB1.
	Point is moved.
	
	
	

	70. 
	Clear the large pane.
	Graphics and tools are cleared from the main pane.
	
	
	

	71. 
	From the Volume menu, open Browser.


	Volume Browser opens.
	
	
	

	72. 
	From the Tools menu of the Volume Browser, select Choose by ID.
	The Choose By ID GUI opens.
	
	
	

	73. 
	In the first column in row A, type kbos for the Boston Metar and press enter to save.
	kbos turns to KBOS.
	
	
	

	74. 
	In the first column in row B, type ksfo for the Sacramento Metar and press enter to save.
	ksfo turns to KSFO.
	
	
	

	75. 
	In the Volume Browser, select Time Series from the settings (Plan View) pull-down menu.  


	The default option is Plan View.
	
	
	

	76. 
	Select point A (tbw3) or point B (tbdw) from the point pull-down menu (next to setting pull-down menu).  


	Depending on which test bed is in use, the appropriate Point is selected.
	
	
	

	77. 
	Select a source: from the Point pull-down menu select Metar.


	Source shows up highlighted (yellow) in the source selection list.
	
	
	

	78. 
	Select a field: from the Basic pull-down menu select Temperature.
	Field shows up highlighted (yellow) in the source selection list
	
	
	

	79. 
	Select a plane: From the Misc pull-down menu select Surface
	Plane shows up highlighted (yellow) in the plane selection list; product shows up highlighted (yellow) in the product selection list.
	
	
	

	80. 
	Select load at the bottom of the Volume Browser.
	Time series loads with temperature displayed and KBOS indicated in the product legend.
	
	
	

	81. 
	Select clear on D2D and close any open windows.
	Graphics and tools are cleared from the main pane.
	
	
	

	82. 
	On the D2D main menu follow this path: File > Select User ID.
	Select User ID GUI opens.
	
	
	

	83. 
	Select Will Leverenz with MB1.
	Will Leverenz is highlighted in yellow.
	
	
	

	84. 
	Press OK.
	GUI closes and user willl is displayed on the D2D title bar.
	
	
	

	85. 
	On the D2D main menu follow this path: File > Procedures > Open.
	Open Procedure GUI opens.
	
	
	

	86. 
	Click on D2D Testcases.
	D2D Testcases is highlighted.
	
	
	

	87. 
	Press OK.
	The D2D Testcases procedure GUI opens.  A list of bundles to choose from is displayed.
	
	
	

	88. 
	Select the DMD bundle labeled with the appropriate radar.
	Bundle is highlighted.
	
	
	

	89. 
	Press load.
	GUI closes, Local dedicated radar product loads (Digital Mesocyclone DMD).  Note that each mesocyclone (target) has a number (ID) attached.
	
	
	

	90. 
	From the Volume menu, open Browser.


	Volume Browser opens.
	
	
	

	91. 
	From the Tools menu of the Volume Browser, select Choose by ID.
	The Choose By ID GUI opens.
	
	
	

	92. 
	In the first column in row C, type ###, where ### is the mesocyclone ID and press enter to save.
	Nothing should change.
	
	
	

	93. 
	In the Volume Browser, under the default option Plan View, select Time Series from the settings pull-down menu. 
	Nothing should change.
	
	
	

	94. 
	Select point C from the point pull-down menu (next to settings pull-down menu).


	Point C is selected.
	
	
	

	95. 
	Select a source: from the Point pull-down menu select Metar.


	Source shows up highlighted (yellow) in the source selection list.
	
	
	

	96. 
	Select a field: from the Basic pull-down menu select Temperature.
	Field shows up highlighted (yellow) in the source selection list
	
	
	

	97. 
	Select a plane: From the Misc pull-down menu select Surface
	Plane shows up highlighted (yellow) in the plane selection list; product shows up highlighted (yellow) in the product selection list.
	
	
	

	98. 
	Select load at the bottom of the Volume Browser.
	Time series loads with temperature displayed and the radar nearest to the selected point is indicated in the product legend.
	
	
	

	99. 
	Select clear on D2D.
	Main pane is cleared of all added graphics and maps.
	
	
	

	100. 
	Bring the D2D Testcases procedure window back to the top again by finding it in the KDE task bar or by clicking the D2D menu bar with MB2.


	D2D Testcases procedure window appears.
	
	
	

	101. 
	Select bundle 2 (use the second group for TBW4).
	Bundle is highlighted.
	
	
	

	102. 
	Press load.
	Local radar product loads: Digital Mesocyclone DMD.  Note that each mesocyclone (target) has a number (ID) attached to it.
	
	
	

	103. 
	Display the points by clicking the points button on the D2D menu bar.  
	Points are displayed and point C is inside the mesocyclone target that was selected in step 77.
	
	
	

	104. 
	From the Maps menu, select METARs.
	The METARs are displayed on the screen.
	
	
	

	105. 
	From the Tools menu, click on Home, then select Put home cursor.
	The Put Home Cursor window opens, and the Home marker is displayed on the screen.
	
	
	

	106. 
	Click MB2 over Home Location in the product legend.
	The Home Location is editable.


	
	
	

	107. 
	Press and hold MB1 over the Home marker, and move it to a new location on the screen.
	The information in the Put Home Cursor window changes as the Home marker is moved to different areas.
	
	
	

	108. 
	In the top of the Put Home Cursor window in the Location selection area, select Station.
	The Station portion of the window now contains an active command line.
	
	
	

	109. 
	Erase the current identification, and type a four-letter identification. Click the Go button at the bottom of the window to move the Home location.
	The Home marker moves to the location of the station specified.
	
	
	

	110. 
	In the top of the Put Home Cursor window in the Location selection area, select City/State.


	The middle portion of the window now contains active command lines to enter city and state names.
	
	
	

	111. 
	Erase current city and state before typing new information.  For TBW3, enter Rutland and VT;  for TBDW, enter Yuba City and CA; for TBW4, type English Bay and AK.  Select Go.


	The Home marker moves to the location selected.
	
	
	

	112. 
	In the Location selection via:  section of the Put Home Cursor window, select Lat/Lon.


	This activates a command line in the Lat/Lon section of the Put Home Cursor window.
	
	
	

	113. 
	Type:  42 for lat and -71 for long (38 and -120 for TBDW).  Note that Longitude must be negative for the W. Hemisphere.  Select Go.
	The Home marker moves to that latitude/longitude location on the displayed image in the large pane.
	
	
	

	114. 
	Select Close in the Put Home Cursor window.
	Window closes.
	
	
	

	115. 
	Clear the large pane.
	Graphics and tools are cleared from the main pane.
	
	
	

	116. 
	Launch the Sunrise/Sunset GUI.  D2D: Tools > Sunrise/Sunset.
	The Sunrise/Sunset GUI launches.
	
	
	

	117. 
	Change Latitude and Longitude settings to valid magnitudes.
	Nothing should change.
	
	
	

	118. 
	Click calculate
	Sunrise/Sunset times and graphic (right side of GUI) changes.
	
	
	

	119. 
	Click “Set at Home location”
	Latitude and Longitude magnitudes change to default setting.  NOTE: Default setting is the location of home.  To view where home is on D2D go to Tools > Home.
	
	
	

	120. 
	Change the month field in the date.
	The new month displays.
	
	
	

	121. 
	Click calculate
	Sunrise/Sunset times and graphic (right side of GUI) changes.
	
	
	

	122. 
	Close the Sunrise/Sunset GUI.
	GUI closes.
	
	
	

	123. 
	Launch the Text Window by clicking Tools > Text Window


	Text Window launches.  
	
	
	

	124. 
	In the Text Window, in the AFOS cmd line, enter SLCADASLC and press Enter.
	The latest message of this type is displayed in the Text Window.
	
	
	

	125. 
	Close the Text Window.  File > Close.
	Text Window closes.
	
	
	

	126. 
	Launch the Units Calculator GUI.  Tools > Units Calculator.  
	The Units Calculator GUI launches.  NOTE: Left column is the input column; right is the output column.
	
	
	

	127. 
	Change the number at the top of the left column.
	The number changes.
	
	
	

	128. 
	Select the unit to convert from in the left column by clicking on the radial button with MB1.


	Unit is selected
	
	
	

	129. 
	Select the unit to convert to in the right column by clicking on the radial button with MB1.
	Unit is selected; output magnitude changes.
	
	
	

	130. 
	Close Calculator window.


	GUI closes
	
	
	

	131. 
	If the Procedures window is already open, skip the next 5 steps.  Else on the D2D main menu follow this path: File > Select User ID.


	Select User ID GUI opens.
	
	
	

	132. 
	Select Will Leverenz with MB1.
	Will Leverenz is highlighted in yellow.
	
	
	

	133. 
	Press OK.
	GUI closes
	
	
	

	134. 
	On the D2D main menu follow this path: File > Procedures > Open.


	Open Procedure GUI opens.
	
	
	

	135. 
	Select the first option with MB1: D2D Testcases.
	D2D Testcases is highlighted in 
	
	
	

	136. 
	Press OK
	GUI closes.
	
	
	

	137. 
	Select bundle 1 of the first group (use the second group for TBW4), then press Load.

Note: digital mesocyclone data (DMD) data does not time-match all other data loaded.  It will be loaded in later steps.
	Local dedicated radar products load: reflectivity (Z), storm track information (STI), hail index (HI), tornado vortex signature (TVS).  
	
	
	

	138. 
	The current frame in D2D may only have Z loaded and may not have STI, HI, & TVS loaded.  This is common because Z is the first thing to store.  Move one frame back by clicking the left arrow key (make sure the D2D window is selected).
	Main pane of D2D will display data from the second most current radar scan.
	
	
	

	139. 
	On the D2D main menu follow this path: Tools > Radar Display Controls.


	Radar Display Controls (RDC) GUI opens.
	
	
	

	140. 
	In the STI (Storm Track Info) section of the RDC GUI, change the type of track to show “past & fcst”.
	Previous, current, and future storm locations and storm tracks are displayed (yellow).
	
	
	

	141. 
	Only display Z & STI by using MB1 to click off HI (Hail Index) & TVS (Tornado Vortex Signature) in the product list (lower right in main pane).
	Z (multi-colored image) and STI (yellow)products are displayed.  All other products are hidden from the main pane and grayed out in the product list.
	
	
	

	142. 
	In the STI section of the RDC GUI, change the magnitude of the number of storms to show to 100.


	More storm tracks are displayed at the next complete frame update (up to 5 minutes).
	
	
	

	143. 
	In the STI section of the RDC GUI, change  the magnitude of the number of storms to show to 4.


	Three storm tracks are displayed at the next complete frame update (up to 5 minutes).
	
	
	

	144. 
	In the STI section of the RDC GUI, change  the magnitude of the number of storms to show to 20.


	Up to 20 storm tracks are displayed at the next complete frame update (up to 5 minutes).
	
	
	

	145. 
	In the STI section of the RDC GUI, change  the type of track to show “no tracks.”


	Storm tracks are hidden, locations are still displayed with a hollow circle containing the letter X (yellow).
	
	
	

	146. 
	In the STI section of the RDC GUI, change  the type of track to show “past.”


	Previous storm locations (filled circles), tracks, and current storm locations are displayed (yellow).
	
	
	

	147. 
	In the STI section of the RDC GUI, change  the type of track to show “forecast.”
	Future (computer-expected) storm locations (+), future storm tracks, and current storm locations are displayed (yellow).
	
	
	

	148. 
	Only display Z & HI by using MB1 to click off STI and click on HI in the product list (lower right in main pane).
	Z (multi-colored image) and HI (green) products are displayed.  All others are hidden from the main pane and grayed out in the product list.
	
	
	

	149. 
	In the HI section of the RDC GUI, change the pull-down menu settings to:
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	Most points displayed are small solid triangles. (Note: Highs cannot be lower than Lows therefore limits need to be changed in proper order to avoid error)
	
	
	

	150. 
	In the HI section of the RDC GUI, change the pull-down menu settings to:
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	More triangles are displayed; some are hollow small triangles.
	
	
	

	151. 
	In the HI section of the RDC GUI, change the pull-down menu settings to:
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	Most triangles displayed are small and solid.
	
	
	

	152. 
	In the HI section of the RDC GUI, change the pull-down menu settings to:
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	Most triangles displayed are large and hollow.
	
	
	

	153. 
	In the HI section of the RDC GUI, change the pull-down menu settings to:
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	Most triangles displayed are large and solid.
	
	
	

	154. 
	In the HI section of the RDC GUI, change the pull-down menu settings to:
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	Most triangles displayed are small; half are hollow and half are solid.
	
	
	

	155. 
	In the HI section of the RDC GUI, change the pull-down menu settings to:
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	Most triangles displayed are large; half are hollow and half are solid.
	
	
	

	156. 
	Select the DMD bundle labeled with the appropriate radar.
	Bundle is highlighted.
	
	
	

	157. 
	Press load.
	Local dedicated radar product loads: Digital Mesocyclone DMD.  Note that each mesocyclone (target) has a number (ID) attached.
	
	
	

	158. 
	In the DMD section of the RDC GUI, increase the magnitude setting of the Min feature strength.


	Number of mesocyclones detected decreases. (Note that above a certain threshold, none are displayed.)
	
	
	

	159. 
	In the DMD section of the RDC GUI, decrease the magnitude setting of the Min feature strength.


	Number of mesocyclones detected increases on the display.
	
	
	

	160. 
	In the DMD section of the RDC GUI, change  the type of track to show “no tracks.”
	Storm tracks are hidden, storm locations are still displayed with a hollow circle (yellow).
	
	
	

	161. 
	In the DMD section of the RDC GUI, change  the type of track to show “past.”


	Previous storm locations (diamonds), previous storm tracks, and current storm locations are displayed (yellow).
	
	
	

	162. 
	In the DMD section of the RDC GUI, change  the type of track to show “past & fcst.”
	Previous, current, and future storm locations & previous, current, and future storm tracks are displayed (yellow).
	
	
	

	163. 
	In the DMD  section of the RDC GUI, change  the type of track to show “forecast.”
	Future (computer-expected) storm locations (+), future (computer-expected) storm tracks, and current storm locations are displayed (yellow).
	
	
	

	164. 
	Load bundle 3 from the procedure window.
	The local dedicated radar SRM data loads.  The image will be mostly red and green.
	
	
	

	165. 
	Open WarnGen by selecting the WarnGen icon in the upper right of the D2D application.
	The WarnGen GUI opens; an editable interactive WarnGen point appears on the main pane of D2D with text that reads: “Drag me to Storm” 


	
	
	

	166. 
	Minimize the WarnGen GUI; it is not needed for this test case.  Do not close.


	WarnGen GUI is minimized to the KDE toolbar.
	
	
	

	167. 
	With MB1, click and hold the interactive WarnGen point to and move the point; just pick a random location.  Let go of MB1 when move is complete.
	Interactive WarnGen point is moved and storm track line appears.  The storm track is orientated from south to north.  The true storm tracks are more west to east, but we can ignore that for this test case.


	
	
	

	168. 
	In the SRM section of the RDC, toggle between the three options: Storm Motion from WarnGen Track, Average Storm Motion from STI, Custom Storm Motion.


	The image changes: the location of the red & green colors move.
	
	
	

	169. 
	In the SRM section of the RDC, choose Custom Storm Motion.


	Main pane of D2D displays the custom storm motion.
	
	
	

	170. 
	In the SRM section of the RDC, change the direction of the relative motion.


	The image changes: the location of the red & green colors move.
	
	
	

	171. 
	In the SRM section of the RDC, change the speed of the relative motion.


	The image changes: the location of the red & green colors move.
	
	
	

	172. 
	Left click on the desk top & select Terminal.
	A terminal window opens
	
	
	

	173. 
	Remove any Range Rings history.  Type the following on the command line:

· rm /tmp/Range*


	These files may not exist, but that is not a problem.  If there are any range files, they are removed.
	
	
	

	174. 
	Clear the main pane.
	Graphics and map backgrounds clear from the main pane.
	
	
	

	175. 
	From the Scale pull-down menu (left side of toolbar), select CONUS (Marine on TBW4).
	Scale changes to CONUS (Marine on TBW4 for this case).
	
	
	

	176. 
	From the Tools menu, select Range Rings.
	Range Ring GUI opens.
	
	
	

	177. 
	Toggle on one of the radars by clicking the box next to the radar ID (KXXX or sample).
	The box changes to a bright color.
	
	
	

	178. 
	Type the following numbers into the radii text boxes to the right:  

250 175 50
	The numbers are displayed in text boxes.
	
	
	

	179. 
	From the Labels pull-down menu select C123 and click Apply. 
	Rings appear around the selected radar, and the center and three rings are labeled.  (C labels the center, 1,2, and 3 label the rings.)
	
	
	

	180. 
	Explore options in steps 161-163: try a different location (if any), change the radii, and choose different label options.


	Changes are made.  Location, radii, and labels are altered.  (Remember to use “-“ for longitude.)
	
	
	

	181. 
	In the New at: section create a movable ring, select a point, enter a radius, and click Apply.
	New location and radius is displayed on main pane.
	
	
	

	182. 
	Click on Clear on the D2D toolbar menu.
	Product is cleared from the main pane.
	
	
	

	183. 
	If the LAPS data from step 48 was not checked at that time, return and check it now, then return here to exit.
	The LAPS data should have been updated by now.
	
	
	

	184. 
	Clear the display.
	The display clears.
	
	
	

	185. 
	Select the following:

Scale: wfo

kxxx > kxxx Best Res Vel > 0.5
	The kxxx 0.5 Velocity (kts) 8 bit product is displayed.
	
	
	

	186. 
	On the D2D main menu follow this path: Tools > VR Shear.
	The VR – Shear (Editable) tool launches. This tool comes up editable.
	
	
	

	
	Using MB 1, move the end points of the VR Shear line over an area of velocity. Or using MB 2 on the VR Shear line, move the entire line to a new position.

Note: If you are zoomed in over an area when you load VR -Shear, and the VR – Shear Baseline does not appear, press MB3 to 'snap' the VR Shear line to where the mouse cursor is located.
	The end points of the VR Shear tool are relocated.

The VR – Shear line snaps to the position of the mouse cursor.
	
	
	

	187. 
	When the line is in place, note the speed difference (kts), distance between end points (nautical miles), shear (s-1), and distance from radar (Nmi) are automatically plotted next to the end points and in the upper left corner of the large display pane.

A positive shear value indicates cyclonic shear, while a negative value indicates anticyclonic shear. 

Move the VR -Shear line so that the end points are not directly over velocity data. The phrase 'no data' is reported for the shear value.
	Speed difference (kts), distance between end points (nautical miles), shear (s-l) and distance from radar (Nmi) are automatically plotted next to the end points and in the upper left corner of the large display pane.

'No data' is reported when the line is moved over so that the end points are not directly over velocity data.
	
	
	

	188. 
	Clear the display.

Select the following:

kxxx > kxxx four panel > Best Res Z/V > [selection of choice]

Load the VR – Shear tool.

Verify the VR – Shear Tool overlay is loaded in different colors for each panel (actually four copies of the program running) and each behaves independently. Note that the user must make the tool editable with MB2.

Position the VR Shear line where appropriate and note the plotted reports for each pane.

Clear the display.
	The display clears.

A 4-panel Z/V loads.

The VR – Shear tool loads.

The VR – Shear tool is a different color in each pane and each behave independently.

The plotted reports are as described in Step 188.

The display clears.
	
	
	

	189. 
	Click on File | Exit
	The application closes and the test case is completed.
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