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Test Case #: Baseline_WSR-88D_Dual_Polarization
Test Case Description: Provide capability in AWIPS to request, ingest and display WSR-88D Dual Polarization data.
Requirements: 

Dual polarization product ingest and display capability will be added to AWIPS in OB8.3. These products will become available with the release of ORPG build 11 which is expected in mid 2009.

1. Ingest Dual Pol Products 
a. AWIPS will ingest the following dual pol products: 
   TABLE 1
   Product                      mnemonic  #data levels  product code    resolution
Differential Reflectivity       ZDR          16          158            1.00
    “                      “          256          159            0.25
Correlation Coefficient          CC          16          160            1.00
    “                      “          256          161            0.25
Specific Differential Phase     KDP          16          162            1.00
    “                      “          256          163            0.25
Hydrometeor Classification       HC          16          164            1.00
    “                      “          256          165            0.25
Melting Layer                    ML          16          166            N/A
One Hour Accumulation           OHA          16          169            2.00
Digital Accumulation Array      DAA         256          170            0.25
Storm Total Accumulation        STA          16          171            2.00
Digital STA                     STA         256          172            0.25
Digital User Selectable Accum   DUA         256          173            0.25
Digital One Hour Diff Accum     DOD         256          174            0.25
Digital Storm Total Diff Accum  DSD         256          175            0.25
Digital Inst. Precip Rate       DPR       65536          176            0.25
Hybrid Scan HC                  HHC         256          177            0.25
b. AWIPS will provide the request for these products via the RPS, OTR, and RMR request applications. The request will be in the same format as for the TVS Rapid Update (TRU) product. The user will be able to select from the following: 

i. a specific elevation angle 

ii. all elevation angles 

iii. all elevations at or below a specified elevation angle 

iv. the lowest 'n' elevation angles 

c. AWIPS will provide the capability to enable multiple user selectable (DUA) products to be stored in such a way as to enable time series looping. 
2. Display and Processing 

a. When products are selected for display, they will be decoded from the ingest format to display format, as is currently done. AWIPS will decode the DPR product from the Generic Radial format to display format.

b. D-2D will display at the full resolution the following dual pol products: ZDR, CC, KDP, HC, Melting Layer, and QPE produced by the RPG.

c. D-2D will display 4-bit products using default color tables contained in the product specification ICD; 8-bit product colors will be obtained by ramping 4-bit product colors.

d. For 4-bit products, D-2D will use data levels contained in the product description block, since they can be modifiable at the RPG.

e. The 4-bit products will be displayed explicitly from the 4-bit menu.

3. Linked 4-panel multi-product all-tilts with cursor readout: 

a. AWIPS will provide a 4-panel layout containing either single or different paired products in each panel. Each type of 4-panel layout will have an all-tilts selection, with navigation and toggle capabilities.

b. The following default panel layouts will be provided on D-2D: 

i. The simple 4-panel display will contain Z, ZDR, CC, and HC or KDP in the upper left, upper right, lower left, and lower right, respectively. There will be no toggle capability.

ii. In the general purpose 4-panel display, the individual panels will contain Z/V, ZDR/SRM, CC/HC, and KDP/STA.

iii. The precipitation 4-panel display will contain STA/OHA, STP/OHP, DSD/DOD, and DPR/HHC.

c. Ideally, the cursor will remain linked on all four panels, and cursor readout will display the values of all four products currently on display.

4. Melting Layer display 
D-2D will display the HCA melting layer information, which is four contours showing the top and bottom of where the beam starts to intersect and is centered on the melting layer. This melting layer may be displayed for each tilt. 

5. Volume Browser 
The dual polarization products will be displayable in the Volume Browser either as a Constant Altitude PPI (CAPPI) or cross section. 


Data Input: N/A

Prerequisite Conditions: This test case assumes that all the servers on the AWIPS work site are operating normally, and the AWIPS work site is not experiencing any network anomalies, which may adversely affect communications between the various servers of the work site.
	Step #
	Action / Inputs
	Expected Outputs
	Pass(P)/

Fail(F)

Pending (Pen)
	DR #, Name, Description for failed step 
	Special Needs / Comments

	1. 
	Open a terminal window and log on to the dx2 server:

· ssh dx2f
	Logged in on dx2 server
	
	
	

	2. 
	On dx2f, verify that the ingest processes are running. Use the ps -ef  command for the following processes:

RadarServer
ORPGCommsMgr
RadarStorage
DialServer
RMR_Server

· ps –ef | grep <process name> | grep –v grep
Make a note of the PID for each process.

	The listed processes are running.
Note: There will be a ORPGCommsMgr process for each dedicated radar site.

An alias may be set to expedite this process:

alias proc ‘ps –ef | grep !* | grep –v grep’
Then test each process with:

proc <process name>
	
	
	

	3. 
	Verify that log files are created for the above processes.

· logs
     or

· cd /data/logs/fxa/<YYYYMMDD> 
· ls -1 | grep <process name>
	Log files exist for the following radar processes referenced to the PIDs found in Step 2.

RadarServer
ORPGCommsMgr
RadarStorage
DialServer
RMR_Server

Note: There will be a ORPGCommsMgr log file for each dedicated radar site.
There may not be log files for the DialServer and RMR_Server processes if there were no one time requests or multiple requests, respectively. Check the previous day for these logs, or wait to submit radar requests.
	
	
	

	4. 
	Verify in the ORPGCommsMgr log file that the following products are being received by searching for the product codes as defined in the table below.


Product

Product
Code

ZDR

158

ZDR

159

CC

160

CC

161

KDP

162

KDP

163

HC

164

HC

165

ML

166

OHA

169

DAA

170

STA

171

STA

172

DUA

173

DOD

174

DSD

175

DPR

176

HHC

177

· grep ‘Product ###’ ORPGCommsMgr<PID>*
where ### is the Product Code #.
	Dual Pol radar products are received and being stored in the proper directories.

Note: 
### is the Product Code and PID is the process ID associated with a kxxx radar found in Step 2.

If all the products are not coming in, place the product in the current RPS List and wait for the product to arrive (see Steps 35-40 at the end of this test case).
	
	
	

	5. 
	Verify that the products are stored in their proper directories under

/data/fxa/radar/kxxx/<Product ID>/<elev>/<res>/<level> as specified in the Table 1 in the test case Requirements.
· cd /data/fxa/radar/kxxx

· ls –lR <Product ID> | more
For the following Product IDs: ZDR, CC, KDP, HC, ML, OHA, DAA, STA, DUA, DOD, DSD, DPR, HHC


	Products are being stored in the proper directories.

kxxx is one of the ORPG radars.

elev is the elevation angle

res is the resolution\
Note: The Digital User Selectable Accum (DUA – Product #173) may not be available.
	
	
	

	6. 
	Verify that the products are correctly purged:

· cd /awips/fxa/data/localizationDataSets/XXX
Where XXX is the current testbed localization.

Find the data keys, for each of the Dual Pol products listed in Step 4, in the radarDataKeys.txt file.

In the radarPurgeInfo.txt file, verify that there are entries similar to:

1270480895 | 1270415360,1270480760 |  | 2- | 60 | 72,,~1:00

for each data key, so that the key falls within the range specified in the second field.
	The entry is present in the radarPurgeInfo.txt file.
Testbed     Localization

TBDR       RSA
TBDW      STO

TBW3       BOX

TBW4       AFC
	
	
	

	7. 
	Exit from the dx2f server and close the terminal window.


	User is logged off from dx2f.
	
	
	

	8. 
	Open a D-2D session and set the Scale to WFO.
	D-2D is opened and the scale is set.
	
	
	

	9. 
	On a D-2D graphics display, select one of the kxxx dedicated radar menus. The menu should look similar to this:
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	The menu is as expected. 
	
	
	

	10. 
	Exit from D-2D.

Open a terminal window. When dual polarization radar data are available, run the following script as user fxa to reorganize the radar menus to accommodate the dual polarization products:

· sudo su - fxa

· $FXA_HOME/data/localization/scripts/dualPolTurnKey.csh
Restart D-2D as was done in Step 8.

	This script, when executed without any arguments, will convert the radar menu layout to the new dual polarization focused layout.
	
	
	

	11. 
	The resulting kxxx menu will look similar to this:
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	The menu is as expected.
	
	
	

	12. 
	Load a few products from the dual polar focused menu.
	Products load as expected.
	
	
	

	13. 
	Exit from D-2D.

To back out the dual polarization reorganized menus, execute the following as user fxa:

· $FXA_HOME/data/localization/scripts/dualPolTurnKey.csh –

Restart D-2D as was done in Step 8.

Verify that the menu resulting from rolling back the menu changes looks identical to the original kxxx menu.
	The original kxxx menu is restored.

Note the '-'. This is the argument needed in order for the script to roll back to the previous menu layout.
	
	
	

	14. 
	Select the kxxx Dual Pol Prods pull right menu. The menu looks like this:
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	The menu is as expected. 
	
	
	

	15. 
	Select the kxxx Diff Refl (ZDR) Pull Right Menu from the Dual Pol Prods menu
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Load each of the above Diff Refl products. Verify that each menu item can be displayed and that the product auto-updates. 
	Pull right menu is as expected and the products load and auto-update.

Note: If the product is not routinely ingested, send out a One-time Request. Verify the product is ingested and displays.
	
	
	

	16. 
	Select the kxxx Corr Coeff (CC) Pull Right Menu
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Load each of the above Corr Coeff products. Verify that each menu item can be displayed and that the product auto-updates.
	Pull right menu is as expected and the products load and auto-update.

Note: If the product is not routinely ingested, send out a One-time Request. Verify the product is ingested and displays.
	
	
	

	17. 
	Select the kxxx Spec Diff Ph (KDP) Pull Right Menu
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Load each of the above Diff Ph products. Verify that each menu item can be displayed and that the product auto-updates.
	Pull right menu is as expected and the products load and auto-update.

Note: If the product is not routinely ingested, send out a One-time Request. Verify the product is ingested and displays.
	
	
	

	18. 
	Select the kxxx Hydrometeor Class (HC) Pull Right
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Load each of the above Hydrometeor Class products. Verify that each menu item can be displayed and that the product auto-updates.
	Pull right menu is as expected and the products load and auto-update.

Note: If the product is not routinely ingested, send out a One-time Request. Verify the product is ingested and displays.
	
	
	

	19. 
	Select the kxxx Melting Layer (ML)
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Load each of the above Melting Layer products. Verify that each menu item can be displayed and that the product auto-updates.
	Pull right menu is as expected and the products load and auto-update.

Note: If the product is not routinely ingested, send out a One-time Request. Verify the product is ingested and displays.
	
	
	

	20. 
	Select the Dual Pol Base Data 4 Panel menu.
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Load each of the above Dual Pol Base Data 4 Panel products. Verify that each menu item can be displayed and that the product auto-updates.
	Pull right menu is as expected and the products load and auto-update.

Note: If the product is not routinely ingested, send out a One-time Request. Verify the product is ingested and displays.
	
	
	

	21. 
	Select the Dual Pol HCA 4 Panel menu.
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Load each of the Dual Pol HCA 4 Panel products. Verify that each menu item can be displayed and that the product auto-updates.
	Pull right menu is as expected and the products load and auto-update.

Note: If the product is not routinely ingested, send out a One-time Request. Verify the product is ingested and displays.
	
	
	

	22. 
	Load the Dual Pol Precip products from the kxxx Dual Pol Prods menu in the Dual Pol Precip section. Menu entries look like this:
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Verify that the Dual Polization Product on the kxxx Precip Menu load and auto-update.
	Dual Pol Precip products load and auto-update. 
	
	
	

	23. 
	Verify that color tables exist for Dual Polarization products:

Select the Image Properties icon on D-2D or Image Properties from the D-2D Options menu.

Select the Radar pull-right menu and select the DualPol pull-right menu. The following color tables are available:

Differential Refl
Correlation Coeff
Spec Differential Phase
Hydrometeor Class
Precip Accumulation
Precip Rate

Select each of the above color tables and note the resulting color curves.
	A default color table exists for each product and the color table can be changed using the Image Properties Dialog.
	
	
	

	24. 
	Close the Image Properties dialog box.
	The GUI is closed.
	
	
	

	25. 
	Select the following:

kxxx > Applications > One time Request...

The Dedicated - One Time Request dialog box opens. It looks similar to this:

[image: image12.png]" . Dedicated - One Time Request

RPG:

Reflectivity (2)

Request Interval:

Elevation(s):
Al

- All at or below:

5

el

~ Selected 05—
Data levels:

Resolution:

Time: A cument  Latest - Selected

Selected time: [Current.





	The Dedicated - One Time Request dialog box appears.

Note: kxxx is a dedicated radar.

	
	
	

	26. 
	In the Dedicated - One time Request dialog box for the local radar, open the Product menu. In this menu, observe the following entries:

Dual Pol Base Prods (pull right)
Hydrometeor Class (HC)
Melting Layer (ML)

The Dual Pol Base Prods pull right menu has the following menu options:

Differential Refl (ZDR)
Correlation Coeff (CC)
Specific Diff Phase (KDP)

Further down in the products menu, there is an option for the Dual Pol Precip products. This pull right includes the following menu options:

Digital Inst Precip Rate (DPR)
Hybrid Hydrometeor Class (HHC)
One Hour Accum (OHA)
One Hour Unbiased Accum (DAA)
Storm Total Accum (STA)
User Select accum (DUA)
One Hour Diff (DOD)
Storm Total Diff (DSD)
	Menu options are available as described.
	
	
	

	27. 
	After selecting a Dual Pol product, the user can select the following from the section labeled Elevation(s) :

All
All at or below:
Lowest 'n'
Selected

Selected is the default option.

	

Note: The Elevation options are not available for the Dual Pol Precipitation products. 


	
	
	

	28. 
	Submit a One Time Requests for each of the products in Step 26. If the correct information for the product is not entered, the user may receive this dialog:
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Load each product and verify that the displayed products and menus auto-update.


	Correct entries can be created by looking at Table 1 in the test case requirements.

The products are retrieved from the RPG.

The displayed products and the menus options auto-update.

Note that when requesting a Digital User Selectable Accum (DUA) product, that the Time span can be no less than 15 minutes.
	
	
	

	29. 
	Repeat the previous step using different Elevations and verify that the correct products are received from the RPG.
	The correct products are received from the RPG.
	
	
	

	30. 
	Select the following:

kxxx > Applications > Radar Multiple Request...

where kxxx is the local radar.

Observe the Radar Multiple Request (RMR) dialog box.
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	The Radar Multiple Request (RMR) dialog box opens.
	
	
	

	31. 
	In the RMR dialog box, select the New Request... button.
	The New Request dialog box opens.
	
	
	

	32. 
	Give the Request a name and indicate if the request is a Single request or a Multiple Request. If the request is a Multiple Request, select how often to repeat and the duration of the request.


	Request is created.
	
	
	

	33. 
	Click on the OK button.
	The Add Products dialog box opens.
	
	
	

	34. 
	Select the Radar Type, and choose a Dial Out or Dedicated RPG.
	The radar is selected.
	
	
	

	35. 
	In the Products section, open the menu and in the menu, observe the following entries:

Dual Pol Base Prods (pull right)
Hydrometeor Class (HC)
Melting Layer (ML)
	Menu contains the listed products.
	
	
	

	36. 
	In the Product section, note the Dual Pol Base Prods pull right menu. This menu contains the following menu options:

Differential Refl (ZDR)
Correlation Coeff (CC)
Specific Diff Phase (KDP)

Further down in the menu, note the Dual Pol Precip pull right menu. This menu contains the following menu options:

Digital Inst Precip Rate (DPR)
Hybrid Hydrometeor Class (HHC)
One Hour Accum (OHA)
One Hour Unbiased Accum (DAA)
Storm Total Accum (STA)
User Select Accum (DUA)
One Hour Diff (DOD)
Storm Total Diff (DSD)

Select a Dual Pol product, Request Interval, and Elevation(s). Again, note that with the selection of some of the Dual Pol products, the Elevation(s) default is Selected and that the other available selections are All, All at or below and Lowest 'n'.
	













The Dual Pol Base Prods pull right menu contains the indicated menu options.




The Dual Pol Precip pull right menu contains the indicated menu options.

	
	
	

	37. 
	Create a request with various Dual Pol Products and submit the request. If the correct information for the product is not entered, the user may receive this dialog:
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Correct entries can be created by looking at Table 1 in the test case requirements.

Verify that the products come in from the specified radar and that the product displays and menus auto-update.


	The request is submitted.

The specified products are received from the correct radar and the product displays and menus auto-update.

Note that when requesting a Digital User Selectable Accum (DUA) product, that the Time span can be no less than 15 minutes.

Also note that when requesting a single DUA product, the interface is similar to the One Time Request for the DUA.
	
	
	

	38. 
	Repeat with the other Dual Pol Products listed in Step 36.
	As expected.
	
	
	

	39. 
	Select the following:

kxxx > Applications > RPS List Editor...

where kxxx is any radar.
	

The RPS List Editor dialog box opens.

	
	
	

	40. 
	Select View->Current List… on the RPS List Editor menu. Then choose a kxxx radar.
	The current RPS product list is displayed for the selected radar.
	
	
	

	41. 
	In the RPS List Editor dialog box, select Add.
	The Add Product dialog box opens.
	
	
	

	42. 
	In the Product section of the Add Product dialog box, note the following:

Dual Pol Base Prods (pull right)
Hydrometeor Class (HC)
Melting Layer (ML)

The Dual Pol Base Prods pull right offers the following options:

Differential Refl (ZDR)
Correlation Coeff (CC)
Specific Diff Phase (KDP)

Further down in the menu, note the Dual Pol Precip pull right menu. This menu contains the following menu options:

Digital Inst Precip Rate (DPR)
Hybrid Hydrometeor Class (HHC)
One Hour Accum (OHA)
One Hour Unbiased Accum (DAA)
Storm Total Accum (STA)
User Select Accum (DUA)
One Hour Diff (DOD)
Storm Total Diff (DSD)
	The menus are as described.
	
	
	

	43. 
	Select a Dual Pol Product and add it to the current request. If the correct information for the product is not entered, the user may receive this dialog:
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Correct entries can be created by looking at Table 1 in the test case requirements.

	Selected is the default Elevation option.

Note that when requesting a Digital User Selectable Accum (DUA) product, that the Time span can be no less than 15 minutes.

With the selection of some Dual Pol products, note the Elevation(s) portion of the dialog box. Note the available selections: 


All
All at or below:
Lowest 'n'
Selected
	
	
	

	44. 
	Click on Send and choose the same radar selected in Step 40.

Exit from the RPS List Editor:

File->Exit

If an Unsaved Changes dialog box appears, select YES to exit the RPS editor without saving the updated list.
	The new RPS request list is submitted.
	
	
	

	45. 
	After the request list is submitted, verify that the products display and that both the display and the menus auto-update.
	The products are received and the display and menus auto-update.
	
	
	

	46. 
	Verification that Dual Pol products are available from the Volume Browser and that they can be loaded:

Clear D-2D and select the Regional scale.

Select and load the Dual Pol products from the Volume->Browser menu on D-2D. 

Set the view to Cross Section.

Select Tools->Choose by ID
And enter the radar of choice (e.g. KENX) in the HOME field at the bottom of the GUI and press Enter. Then enter the same radar for a specified baseline and press Enter.
Source: Volume->Radar

Fields: Other-><Dual Pol Product>

Planes: Select a specified baseline.

Load a Dual Pol product:

Diff Refl

Corr Coeff

Spec Diff Phase

Hydrometeor Class
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Product is loaded.

The dual polarization products will be displayable in the Volume Browser as a Cross Section.
	
	
	

	47. 
	Repeat Step 46 for other Dual Pol products.
	Products are loaded.
	
	
	

	48. 
	Set the view to Plane View.

Select Tools->Choose by ID

And enter the radar of choice (e.g. KENX) in the HOME field at the bottom of the GUI
Source: Volume->Radar

Fields: Radar-><Dual Pol Product>

Planes: Select a height.

Load a Dual Pol product:

Diff Refl

Corr Coeff

Spec Diff Phase

Hydrometeor Class
	Product is loaded.

The dual polarization products will be displayable in the Volume Browser as a Constant Altitude PPI (CAPPI).

Note: The ‘<’ button in D-2D may have to be pressed to display the data.
	
	
	

	49. 
	Repeat Step 48 for other Dual Pol products.
	Products are loaded.
	
	
	

	50. 
	Using the Volume Browser, create a radar data bundle using radar data, and save the bundle in a procedure and exit the dialog.


	A radar bundle is created using the Volume Browser.

e.g.:

Select Volume->Browser
Select Plan View
Sources: Volume->Radar
Fields: Radar->Reflectivity
Planes: Hgt->1500m

Highlight the listed data and press the Load button
Files->Procedures->New…

Press the Copy In button

Save

The bundle is saved.
	
	
	

	51. 
	Clear D2D.

On the main D2D menu, select the following:

Options > Data Scale

Load the radar bundle created in Step 50. 
	The Data Scale option has no effect on the bundle. For example, if the bundle was created on the Regional scale and the Data Scale button was selected, the resulting display would be displayed on the Regional Scale instead of a more local scale.

	
	
	

	52. 
	On the graphics workstation, select the following:
Volume > Browser...
In the Planes section, note the addition of Temp. The selections in Temp look like this:
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	The Volume Browser is displayed, and a Temp menu exists.
	
	
	

	53. 
	Load some products using the Temp menu.
	Products load as expected.
	
	
	

	54. 
	Note in the Misc menu, that the Radar Tilts pull-right has been removed. This Planes selection is now a separate menu Tilts.
	The Radar Tilts pull-right menu is removed from the Misc menu.
	
	
	

	55. 
	Note in the Lyrs menu, the addition of the Temp layers:
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In the Lyrs menus, Temp layers exist.
	
	
	

	56. 
	Load some products using the above Temp menu.
	Products load as expected.
	
	
	

	57. 
	Clear D2D and set scale to Regional.
	Main pane of D2D is cleared and scale is set to Regional.
	
	
	

	58. 
	In D-2D, select the following: 

kxxx > 
kxxx four panel > 
Best Res Z/V > 
0.5 1.5 2.4 3.4
Observe that the four panel display displays the following:

Upper Left: 0.5 Z + 0.5 V

Upper Right: 1.5 Z + 1.5 V

Lower Left: 3.4 Z + 3.4 V

Lower Right: 2.4 Z + 2.4 V

or the best elevations available.
	Displays are as expected.
	
	
	

	59. 
	Select Delete (in the cluster of keys above the up-down, right-left arrows). This will enter the Panel/Combo Rotate mode.

Observe that the resulting display is the 0.5 elevation, with only the Reflectivity product displayed. In the lower left corner of the display, note the +. This indicates that you are in the Panel/Combo Rotate mode.

Continue selecting the Delete key. As you continue selecting the key, note that the following are displayed:

Hits on the Delete Key

Display

2nd
1.5 Z

3rd
2.5 Z

4th
3.5 Z

5th
0.5 V

6th
1.5 V

7th
2.5 V

8th
3.5 V

Continuing to select the Delete key will start the sequence again.

Note that hitting the Backspace key presents the previous display.
	The display in the upper left four-panel is displayed. A + is displayed in the lower left corner.

Hitting the Delete key sequences through the eight products of the four-panel.

Hitting the Backspace key presents the previous display.
	
	
	

	60. 
	The numbers 1 through 4 on the regular keyboard will select the reflectivity (Z) elevation for panels 1 through 4 and 5 through 8 will select the velocity (V) elevation for panels 1 through 4. That is:

Keyboard Number
Display

1

0.5 Z

2

1.5 Z

3

2.5 Z

4

3.5 Z

5

0.5 V

6

1.5 V

7

2.5 V

8

3.5 V

Or depicted like this:

1 + 5

2 + 6

4 + 8

3 + 7

With the mouse on the display, click and hold the right mouse button (3) and observe the pop-up menu. Note the Rotate Panels selection. Selecting Rotate Panels will step through the display sequentially.
	The regular keyboard numbers are mapped to the indicated displays.

The pop-up menu selection Rotate Panels sequences through the display.
	
	
	

	61. 
	To exit the Panel/Combo Rotate mode, select End above the up-down, right-left arrows. Observe the return to the original four panel display.

Repeat with other four-panel displays.
	Selecting End exits the Panel/Combo Rotate mode.
	
	
	

	62. 
	Select Clear in D-2D
	Main pane cleared.
	
	
	

	63. 
	Load a four-panel radar display (for example the Best Res Z/V > 0.5 1.5 2.4 3.4) and enter the Panel/Combo Rotate mode. Note in this example that the kxxx 0.5 Z product is loaded.

Click and hold the right mouse button (3) to bring up the right pop-up menu, and select All Panel Sample. Move the cursor over the 0.5 Z radar display and depress the left mouse button (1). Observe the sample output in the following order (from top to bottom):

0.5 Z

1.5 Z

2.5 Z

3.5 Z

0.5 V

1.5 V

2.5 V

3.5 V
	The four-panel product displays.

All eight products sample output is displayed.
	
	
	

	64. 
	On the display, right click to access the pop-up menu. Select Sampling. Move the mouse over the display and note that the sample data output is continual.

Deselect Sampling and note that the continual sampling is disabled.
	Continual sampling is enabled with the pop-up menu selection Sampling.

Deselecting Sampling terminates the continual readout.
	
	
	

	65. 
	Exit D-2D
	The test case is complete.
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