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1.0 SCOPE 

See Software Test Plan. 
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2.0 APPLICABLE DOCUMENTS 

2.1 Source Documents 
• None 
 

2.2 Reference Documents 
• Software Test Plan for the Advanced Weather Information Processing System Project, 

Contract #DG133W-05-CQ-1067, 4 December 2007 
• Section 2.1.6.4 of the AWIPS D-2D User’s Manual Build 8.1 
• Existing AWIPS 1 test procedures: 

o D2D_Prod_View_1.4.1.11 
• The VPN connection to the Silver Spring NWS AWIPS 1 test bed 
• Release OB8.1 of the Weather Event Simulator (WES) 
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3.0 TEST CASE DESCRIPTION 

This test case illustrates the capability of CAVE to display and manipulate static and animated 
images as well as associated map backgrounds.  This test case also demonstrates a representative 
sample of functionality contained in each of the menus (Options, Tools, Volume, Obs, Upper Air, 
Satellite, koax and Maps). 
 

3.1 Assumptions, Constraints and Preconditions 
• TO8 software has been installed successfully 
• CAVE, EDEX and pgAdmin III are running 
• Test data has been ingested 
• Additional manipulation of data are tested in additional test cases 

o ColorMap_Editor_1.0 
o Skew_T_1.0 
o Vectors_1.0 

 

3.2 Recommended Hardware 
See Software Test Plan. 
 

3.3 Test Inputs 
Section 4.0 below contains the test procedures for this test case.  Sections 2.2 – 2.9 of the Software 
Test Plan contain general test inputs applicable to all TO8 test cases.   
 

3.4 Test Outputs 
The images and data will be displayed in CAVE. 
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4.0 TEST SCENARIO 

Step Action Result Pass/Fail 
1.  Start CAVE. CAVE starts.  
2.  Verify the WarnGen button is in the tool bar. The WarnGen button is in the tool bar.  
3.  Verify the following buttons in the tool bar: 

-Clear 
-First Frame 
-Previous Frame 
-Next Frame 
-Last Frame 
-Loop 
-Toggle Image Combination 
-Loop Controls 
-Image Properties 
-Print 
-Points 
-Baselines 
-Default Pane Layout 
-Three Pane Layout 
-Flash Flood (guidance) 
-Severe Weather (guidance) 

The listed buttons are available from the 
tool bar.  

4.  Verify the following dropdown menus are present in the tool 
bar: 
-Scales (N. Hemisphere, North American, CONUS, Regional, 
State(s), WFO) 
-Frames (1-64) 
-Magnification (0.0, 0.8, 1.0, 1.25, 1.5, 2.0, 2.5) 
-Density (0.33, 0.5, 0.67, 1.0, 1.25, 1.5, 2.0, Max) 

The listed dropdown menus contain the 
listed values.  

5.  Click mouse button 1 on the File menu. A dropdown menu appears.  
6.  Verify the items in the dropdown menu are replicated in the 

‘FileMenu’ screen shot.  
Note: The ‘Exit…’ option is under the CAVE menu. 
(A comprehensive test of the Procedures and History List is in 
the Workstation_Bundles_History_1.0 test case.) 
(A comprehensive test of the Print and Capture Window 
capabilities is found in the Screen_Capture_1.0 test case.) 

The menu items are present.  

7.  Click mouse button 1 on the View menu. A dropdown menu appears.  
8.  Verify the items in the dropdown menu are replicated in the 

‘ViewMenu’ screen shot.  
The menu items are present.  

9.  From the ‘koax’ dropdown menu, select an available 
composite reflectivity radar image. 
(A comprehensive test of the radar is in the 
Radar_Display_1.0 test case.) 

The radar image displays in CAVE.  

10.  From the ‘Satellite’ dropdown menu, verify available 
products display the date and time (day.time) adjacent to the 
product.  Then load an available satellite image from the 
‘Satellite’ dropdown menu. 
Then hold down MB3 on the Satellite product ID in the 
product legend and select the ‘Move Down’ option. 

The date and time are located adjacent to 
the available products. 
A satellite image displays in CAVE. 
The radar image appears above the 
Satellite image. 

DR #690 
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11.  From the ‘Maps’ dropdown menu, select ‘Cities’. Cities are displayed in CAVE.  
12.  Click mouse button 1 on the ‘Loop’ button. The images displayed in CAVE begin 

looping.  

13.  Click mouse button 1 on the Options menu. A dropdown menu appears.  
14.  Verify the items in the dropdown menu are replicated in the 

‘OptionsMenu’ screen shot.  
The menu items are present.  

15.  From the ‘Options’ dropdown menu, select ‘Loop 
Properties…’. 

A ‘Loop Properties’ window opens.  

16.  Increase the Forward speed to 10. The loop increases its speed.  
17.  Set the First frame dwell and Last frame dwell to 0 seconds. 

Then close the ‘Loop Properties’ window. 
The loop progresses continuously without 
pause.  
The ‘Loop Properties’ window closes. 

 

18.  Click mouse button 1 on the ‘Clear’ button. The CAVE display clears.  
19.  Click mouse button 1 on the Tools menu. A dropdown menu appears.  
20.  Verify the items in the dropdown menu are replicated in the 

‘ToolsMenu’ screen shot.  
The menu items are present.  

21.  From the ‘Tools’ dropdown menu, select ‘Baselines’. Baselines display in CAVE.  
22.  Click mouse button 2 on the Baselines product ID in the 

product legend if the baselines are not in edit mode. 
The Baselines become editable.  

23.  Modify a line using the endpoints. The Baseline is modified.  
24.  Click mouse button 1 on the ‘Clear’ button. The CAVE display clears.  
25.  Click mouse button 1 on ‘Upper Air’ in the menu bar and 

select an available RAOB product. 
A sounding displays in CAVE.  

26.  Close the Skew_T tab. The Skew-T tab closes.  
27.  Click mouse button 1 on ‘Obs’ in the menu bar and select the 

‘Surface Plot’ product. 
The Station Plots display in CAVE.  

28.  Click mouse button 1 on the ‘Clear’ button. The CAVE display clears.  
29.  Click mouse button 1 on ‘Volume’ in the menu bar and select 

‘Browser…’. 
The Volume Browser window opens.  

30.  Request an available product from within the Volume 
Browser. 

The product displays in CAVE.  The 
Volume Browser remains open. 

 

31.  Close the Volume Browser. 
(A comprehensive test of the Volume Browser is found in 
VolumeBrowser_1.0 test case.) 

The Volume Browser closes.  

32.  Start the loop by clicking mouse button 1 on the ‘Loop’ 
button in the tool bar. 

The data loops in CAVE.  

33.  Stop the Loop.  Then click mouse button 3 on the contoured 
product ID in the product legend and select ‘Line Width’.  Set 
the line width to 3. 

The loop stops. 
The line width of the contours increases in 
thickness. 

 

34.  Set the scale to WFO.  Then, from the tool bar, change the 
density to 1.5. 

The map adjusts to the WFO scale.  The 
number of contours increases. 

 

35.  Click mouse button 3 on the ‘State/County Boundaries’ 
product ID in the product legend and select ‘Change 
Color…’. 

A color palette window opens.  

36.  Select a color in the ‘Color’ window and click mouse button 1 
on the ‘OK’ button. 

The State and County lines change to the 
selected color. 

 

37.  Then click mouse button 1 on the ‘Clear’ button. CAVE clears.  
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Specific Tools 
Unit Calculator 

38.  From the ‘Tool’ dropdown menu, select ‘Units Calculator…’. A unit calculator appears.  
39.  In the left text box, enter ‘1’ and click mouse button 1 on 

‘Celsius’ on the left side. 
The Celsius unit on the right side becomes 
selected and 1.00000 is entered in the right 
text box. 

 

40.  On the right side, click mouse button 1 on ‘Fahrenheit’. The value changes to 33.80000.  
41.  Verify the Celsius and Fahrenheit units are labeled next to the 

appropriate text box. 
The units are labeled next to the 
appropriate text box. 

 

42.  On the left side, select knots.  Then select mph on the right 
side. 

The unit calculator returns 1kt on the left 
side and 1.15078mph on the right side. 

 

43.  On the left side, select m.  Then select km on the right side. The unit calculator returns 1m on the left 
side and 0.00100km on the right side. 

 

44.  On the left side, select day.  Then select hr on the right side. The unit calculator returns 1d on the left 
side and 24.00000hr on the right side. 

 

45.  On the left side, select mb.  Then select hPa on the right side. The unit calculator returns 1mb on the left 
side and 1.00000hPa on the right side. 

 

46.  Close the Unit Calculator. The unit calculator closes.  
Baselines 

47.  Click mouse button 1 on the Baselines button in the tool bar. 10 baselines labeled A through J display in 
edit mode in CAVE. 

 

48. Click mouse button 2 on the Baselines product ID in the 
product legend. 

The Baselines are put to Normal mode and 
are not editable. 

 

49. Click mouse button 2 on the Baselines product ID in the 
product legend. 

The Baselines return to Edit mode and are 
editable. 

 

50. Verify the product legend displays ‘Interactive Baselines 
(Editable)’. 

The product legend displays ‘Interactive 
Baselines (Editable)’. 

 

51. Click and hold mouse button 1 on the center of a baseline and 
move it to a different location. 

The baseline moves to a different position.  

52. Click and hold mouse button 1 on an endpoint of a baseline 
and move it to a different location. 

The baseline endpoint moves to a different 
position. 

 

53. At the midpoint of a baseline, click and hold mouse button 3 
and select ‘Add Vertex’ from the pop up menu. 

A vertex is added to the baseline.  

54. Click and hold mouse button 3 on the new vertex and select 
‘Delete Vertex’ from the pop up menu. 

The vertex is deleted from the baseline.  

55. Click mouse button 1 on the ‘Clear’ button. CAVE clears.  
56. Reload the Baselines and verify the edits made to the 

baselines remain. 
The baselines load, maintaining the edits 
made to the baselines. 

 

57. Click mouse button 1 on the ‘Clear’ button. CAVE clears.  
Az/Ran Overlay 

58.  From the ‘Tool’ dropdown menu, select ‘Az/Ran Overlay’. The Az/Ran Overlay tool displays in 
CAVE. 

 

59.  Click mouse button 2 on the Az/Ran Overlay product ID in 
the product legend. 

The Az/Ran Overlay tool becomes 
editable. 

 

60.  Click mouse button 1 elsewhere in the main pane of the 
CAVE display. 

The Az/Ran Overlay tool appears at the 
location where the mouse click took place. 

 

61.  Click mouse button 1 on the ‘Clear’ button. CAVE clears.  
Distance Bearing 

62.  From the ‘Tool’ dropdown menu, select ‘Distance Bearing’. 6 Distance Bearing lines labeled A through 
F display in CAVE. 

 

63.  Click mouse button 2 on the Distance Bearing product ID in The Distance Bearing lines become  
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the product legend. editable. 
64.  Click and hold mouse button 1 on the center of a Distance 

Bearing line and move it to a different location. 
The Distance Bearing line moves to a 
different position. 

 

65.  Click and hold mouse button 1 on an endpoint of a Distance 
Bearing line and move it to a different location. 

The Distance Bearing endpoint moves to a 
different position. 

 

66.  Verify the distance and bearing readout was modified, 
displaying the readout at the ‘arrow’s head’. 

The distance and bearing readout modifies 
with the values representing the ‘arrow’s 
head’. 

 

67.  Click mouse button 1 on the ‘Clear’ button. CAVE clears.  
Distance Speed 

68.  From the ‘Tool’ dropdown menu, select ‘Distance Speed’. A point displays in CAVE labeled with 
‘Drag me to feature’.  The Distance Speed 
tool is in edit mode.  A ‘Distance Speed’ 
window appears. 

 

69.  Click and hold mouse button 1 on the point and drag it to 
another position. 
Select ‘Speed’ in the ‘Distance Speed’ window. 

A vector appears with the point at the 
center of the line, tick marks, and speed (in 
knots) and bearing (in degrees) values at 
the arrowhead and point. 

DR # 691 

70.  Press the right arrow key on the keyboard several times. The point moves forward from tick mark 
to tick mark with each key stroke. 

 

71.  Move the point to another position. The vector is modified, the spacing 
between the tick marks is modified, and 
the speed and direction values change. 

 

72.  Press the left arrow key on the keyboard several times. The point moves backward from tick mark 
to tick mark with each key stroke. 

 

73.  Verify the speed and direction values are labeled adjacent to 
the point. 

The speed and direction are labeled 
adjacent to the point. 

 

74.  Click mouse button 1 on the ‘Clear’ button. CAVE clears.  
Home 

75.  From the ‘Tool’ dropdown menu, select ‘Home’. An ‘x’ labeled ‘Home’ appears in CAVE 
at a location specified by localization. 

 

76.  Click mouse button 2 on the Home product ID in the product 
legend. 

The Home tool becomes editable.  

77.  Click mouse button 1 on the Home marker and drag it to 
another location. 

The Home point is relocated.  

78.  Note the new lat/lon position.  Then close and restart CAVE. CAVE is restarted.  
79.  From the ‘Tool’ dropdown menu, select ‘Home’. An ‘x’ labeled ‘Home’ appears in CAVE 

at the new location. 
 

80.  Verify the new lat/lon point was recorded in localization 
under Preferences. 

The Home location lat/lon points are 
modified to the new location 

 

81.  Click and hold mouse button 3 on the display and select 
‘Sample’ and ‘Lat/Lon Readout’. 

The Lat/Lon readout and distance and 
bearing values also display. 

 

82.  Click mouse button 1 on the ‘Clear’ button. CAVE clears.  
Points 

83.  Click mouse button 1 on the Points button in the tool bar. 10 points labeled A through J display in 
edit mode in CAVE. 

 

84.  Click mouse button 2 on the Points product ID in the product 
legend. 

The Points are put to Normal mode and are 
not editable. 

 

85.  Click mouse button 2 on the Points product ID in the product 
legend. 

The Points return to Edit mode and are 
editable. 

 

86.  Verify the product legend displays ‘Interactive Points 
(Editable)’. 

The product legend displays ‘Interactive 
Points (Editable)’. 
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87.  Click and hold mouse button 1 on a point and move it to a 
different location. 

The point moves to a different position.  

88.  Click and hold mouse button 3 on a point and select ‘Delete 
Entire Element’ from the pop up menu. 

The point is deleted from the CAVE 
display. 

 

89.  Click mouse button 1 on the ‘Clear’ button. CAVE clears.  
90.  Reload the Points and verify the edits made to the points 

remain. 
The points load, maintaining the edits 
made to the points. 

 

91.  Click mouse button 1 on the ‘Clear’ button. CAVE clears.  
Sunrise/Sunset 

92.  From the ‘Tool’ dropdown menu, select ‘Sunrise/Sunset…’. The Sunrise/Sunset tool appears.  
93.  Verify the current data was populated in the Year, Month and 

Day text boxes. 
Verify the Zone is set to that set in localization. 

The current date is populated. 
The Zone is set to that set in localization. 

 

94.  Modify the following values: 
-Latitude and Longitude 
-Year 
-Month 
-Day 
Then click mouse button 1 on the ‘Calculate’ button. 

The following values modify: 
-Sunrise Azimuth angle and Time 
-Sunset Azimuth angle and Time 
-Azimuth graphic 
-Time of sunlight 

 

95.  Close the Sunrise/Sunset window. The Sunrise/Sunset window closes.  
Range Rings 

96.  From the Tools menu, select ‘Range Rings’. A ‘RangeRing’ window appears. 
The Range Rings tool loads in edit mode. 

 

97.  In the top half of the ‘RangeRing’ window, activate the 
‘Sample’ section by clicking MB1 on the box. 
 

The box becomes checked.  
Three range rings appear in the main pane 
of the CAVE display. 
 

 

98.  Enter 5, 50, and 100 in the three text boxes from right to left 
respectively. 
Then click MB1 on the Apply button. 

The ‘RangeRing’ window remains open. 
The range rings modify to the changes 
made in the ‘RangeRing’ window. 

 

99.  Under the Labels section, select ‘C123’, then click MB1 on 
the Apply button. 

The three rings become labeled with the 
entered distances within the text boxes of 
the ‘RangeRing’ window.  The center 
point is also labeled ‘Sample’. 

 

100. Deactivate the ‘Sample’ section. 
 

The ‘Sample’ section is disabled. 
The sample range rings are removed from 
the display. 

 

101. Click MB1 on the ‘New at:’ dropdown menu currently 
labeled ‘Lat/Lon’. 

The dropdown menu consists of Lat/Lon, 
points labeled A through J, and Sample. 

DR #732 

102. Select Point A. The ‘Movable Rings’ section within the 
‘RangeRing’ window expands to include 
the ID, Lat, Lon, Radius, and Labels.  The 
Lat and Lon text boxes becomes populated 
with the Lat/Lon position of Point A. 

 

103. Increase the Radius by entering 300 into the Radius text box. 
Then click MB1 on the Apply button. 

The range ring with a radius of 200nm 
appears over Point A. 
 

 

104. From the ‘Labels’ dropdown menu under the ‘Movable 
Rings’ section, select C1. 
Then click MB1 on the OK button. 

The ‘RangeRing’ window closes. 
The range ring is labeled with the 
designated point and the distance entered 
in the Radius text box. 

 

105. Clear the main pane in CAVE. The main pane in CAVE clears.  
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Change Background Color 
106. From the ‘Options’ menu, select ‘Set Background Color…’. A ‘Set Background Color for all Panes’ 

window appears.  The color displayed is 
black. 

 

107. Using mouse button 1, increase the Red value to 255.   
Then click the OK button. 

The color displayed in the ‘Set 
Background Color for all Panes’ window 
is red. 
The background color for all panes 
becomes red.   
The ‘Set Background Color for all Panes’ 
window closes. 

 

108. Repeat step #107, changing the color to black. 
Then click the OK button. 

The color displayed in the ‘Set 
Background Color for all Panes’ window 
is black. 
The background color for all panes 
becomes black.   
The ‘Set Background Color for all Panes’ 
window closes. 

 

 End of test.   
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5.0 REQUIREMENTS VERIFICATION TRACEABILITY MATRIX (RVTM) 

Number Description Test Step(s) 
CAVE_TO8_003 CAVE shall display a menu bar with the look and feel of the legacy 

D2D application 
5-8,13-
14,19-20 

CAVE_TO8_003.1 The menus and submenus shall contain baselined products as in the 
legacy D2D application 

5-8,13-
14,19-20 

CAVE_TO8_003.1.1 The File menu in CAVE shall display items identical to those 
displayed in the legacy AWIPS 8.1 screen shot 'FileMenu' 

5-6 

CAVE_TO8_003.1.2 The View menu in CAVE shall display items identical to those 
displayed in the legacy AWIPS 8.1 screen shot 'ViewMenu' 

7-8 

CAVE_TO8_003.1.3 The Options menu in CAVE shall display items identical to those 
displayed in the legacy AWIPS 8.1 screen shot 'OptionsMenu' 

13-14 

CAVE_TO8_003.1.4 The Tools menu in CAVE shall display items identical to those 
displayed in the legacy AWIPS 8.1 screen shot 'ToolsMenu' 

19-20 

CAVE_TO8_003.2 CAVE shall provide a WarnGen button in the tool bar 2 
CAVE_TO8_003.4 CAVE shall display a tool bar with the look and feel of the legacy 

D2D application 
2,3,4 

CAVE_TO8_003.4.3 CAVE shall provide a Clear button within the tool bar 3 
CAVE_TO8_003.4.4 CAVE shall provide a First Frame button within the tool bar 3 
CAVE_TO8_003.4.5 CAVE shall provide a Previous Frame button within the tool bar 3 
CAVE_TO8_003.4.6 CAVE shall provide a Next Frame button within the tool bar 3 
CAVE_TO8_003.4.7 CAVE shall provide a Last Frame button within the tool bar 3 
CAVE_TO8_003.4.8 CAVE shall provide a Loop button within the tool bar 3 
CAVE_TO8_003.4.9 CAVE shall provide a Toggle Image Combination button within 

the tool bar 
3 

CAVE_TO8_003.4.10 CAVE shall provide a  Loop Controls button within the tool bar 3 
CAVE_TO8_003.4.11 CAVE shall provide a Image Properties button within the tool bar 3 
CAVE_TO8_003.4.12 CAVE shall provide a Print button within the tool bar 3 
CAVE_TO8_003.4.13 CAVE shall provide a Points button within the tool bar 3 
CAVE_TO8_003.4.14 CAVE shall provide a Baselines button within the tool bar 3 
CAVE_TO8_003.4.15 CAVE shall provide a Default Pane Layout button within the tool 

bar 
3 

CAVE_TO8_003.4.16 CAVE shall provide a Three Pane Layout button within the tool 
bar 

3 

CAVE_TO8_003.4.17 CAVE shall provide a Frames dropdown menu within the tool bar 4 
CAVE_TO8_003.4.17.1 The Frames dropdown menu shall allow the user to select the 

frame count from 1-64 in increments of 1 
4 

CAVE_TO8_003.4.18 CAVE shall provide a Magnification dropdown menu within the 
tool bar 

4 

CAVE_TO8_003.4.18.1 The Magnification dropdown menu shall allow the user to select 
the magnification scale from 0.0-2.5 at specified values (0.0, 0.8, 
1.0, 1.25, 1.5, 2.0, 2.5) 

4 

CAVE_TO8_003.4.19 CAVE shall provide a Density dropdown menu within the tool bar 4 
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CAVE_TO8_003.4.19.1 The Density dropdown menu shall allow the user to select the 
density scale from 0-Max at specified values (0.33, 0.5, 0.67, 1.0, 
1.25, 1.5, 2.0, Max) 

4 

CAVE_TO8_003.4.20 CAVE shall provide a Flash Flood guidance button within the tool 
bar 

3 

CAVE_TO8_003.4.21 CAVE shall provide a Severe Warning guidance button within the 
tool bar 

3 

CAVE_TO8_003.6 The menu and submenu products shall display the date and time 
(day.time) of the most recently ingested data if data is available 

10 

CAVE_TO8_017 CAVE shall contain a Unit Calculator tool 38 
CAVE_TO8_017.1 The Unit Calculator tool shall be accessible through the Tool menu 38 
CAVE_TO8_017.2 The Unit Calculator shall display the selected units adjacent to the 

text box 
41 

CAVE_TO8_017.3 The Unit Calculator shall allow the user to enter a numerical value 
into the text box 

39 

CAVE_TO8_017.4 The Unit Calculator shall return a conversion value when a unit has 
been selected in the other column 

40 

CAVE_TO8_017.5 The Unit Calculator shall convert between Temperature units 40 
CAVE_TO8_017.5.2 The Unit Calculator shall convert temperature from Celsius to 

Fahrenheit 
40 

CAVE_TO8_017.6 The Unit Calculator shall convert between Speed units 42 
CAVE_TO8_017.6.3 The Unit Calculator shall convert Speed from knots to mph 42 
CAVE_TO8_017.7 The Unit Calculator shall convert between Distance units 43 
CAVE_TO8_017.7.2 The Unit Calculator shall convert Distance from m to km 43 
CAVE_TO8_017.8 The Unit Calculator shall convert between Time units 44 
CAVE_TO8_017.8.2 The Unit Calculator shall convert Time from day to hr 44 
CAVE_TO8_017.9 The Unit Calculator shall convert between Pressure units 45 
CAVE_TO8_017.9.6 The Unit Calculator shall convert Pressure from mb to hPa 45 
CAVE_TO8_021 CAVE shall contain a baselines tool 47 
CAVE_TO8_021.1 CAVE shall allow launch of Baselines tool from “Tools” menu 21 
CAVE_TO8_021.2 CAVE shall allow launch of Baselines tool from Baselines button 

on tool bar 
47 

CAVE_TO8_021.2.1 The Baselines tool shall load in Edit Mode 47 
CAVE_TO8_021.3 CAVE shall create a default baseline line array if user's 

configuration does not contain a baseline array 
47 

CAVE_TO8_021.3.1 Default configuration shall consist of 10 lines labeled A-J centered 
about user's home location 

47 

CAVE_TO8_021.4 CAVE shall allow the user to display the baselines in Normal 
Mode 

48 

CAVE_TO8_021.4.2 The Baselines in CAVE shall be uneditable while in Normal Mode 48 
CAVE_TO8_021.5 CAVE shall allow manipulation of Baselines through an Edit Mode 51 
CAVE_TO8_021.5.1 CAVE shall display the baselines in Edit Mode 47,49 
CAVE_TO8_021.5.2 CAVE shall allow manipulation of baseline lines in Edit Mode 51,52 
CAVE_TO8_021.5.2.1 CAVE shall display the label 'Interactive Baselines (Editable)' 50 
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when the Baselines are in Edit Mode 
CAVE_TO8_021.5.2.2 The user shall be able to move a baseline using mouse button 1 

(click and hold ) on the baseline 
51 

CAVE_TO8_021.5.2.4 The user shall be able to click and hold mouse button 1 on the 
endpoint to allow movement of the endpoint for the baseline 

52 

CAVE_TO8_021.5.2.6 The user shall be able to add a vertex from the operations menu 
using mouse button 3 

53 

CAVE_TO8_021.5.2.8 The user shall be able to delete a vertex from the operations menu 
using mouse button 3 

54 

CAVE_TO8_021.6 CAVE shall allow toggling of modes using mouse button 2 on 
label describing layer (Interactive Baselines) 

48,49 

CAVE_TO8_021.7 In Edit mode, System shall persist the user's changes to the 
baseline.  Baseline will be persisted as a localization object with 
the CAVE localization 

51-56 

CAVE_TO8_032 CAVE shall contain the Az/Ran Overlay tool 58 
CAVE_TO8_032.1 The position of the Az/Ran Overlay tool shall be editable 59,60 
CAVE_TO8_032.1.5 CAVE shall allow the user to edit the position of the Az/Ran 

Overlay tool by clicking MB1 on the CAVE display 
60 

CAVE_TO8_033 CAVE shall contain the Distance Bearing tool 62 
CAVE_TO8_033.1 CAVE shall allow the user to edit the lines within the Distance 

Bearing tool 
63-65 

CAVE_TO8_033.1.1 CAVE shall allow the user to modify the distance and bearing 
readout by holding down MB1 on an endpoint and displacing the 
endpoint elsewhere in the CAVE display 

65 

CAVE_TO8_033.1.1.1 The distance and bearing readout shall act as the arrow head as to 
determine the appropriate bearing (e.g. if the readout is south of the 
other endpoint, the bearing shall return a value around 180) 

66 

CAVE_TO8_033.1.2 CAVE shall allow the user to relocate the distance and bearing line 
by holding down MB1 on the line and displacing the line elsewhere 
in the CAVE display 

64 

CAVE_TO8_034 CAVE shall contain the Distance Speed tool 68 
CAVE_TO8_034.1 The Distance Speed shall be editable 68-71 
CAVE_TO8_034.2 CAVE shall load the Distance Speed tool in Edit mode 68 
CAVE_TO8_034.2.1 CAVE shall allow the user to drag the 'Drag me to feature' point to 

a point in the CAVE display when initially loading the Distance 
Speed tool 

69 

CAVE_TO8_034.2.2 CAVE shall extend the point to include a vector with tick marks, 
and a speed and bearing reading at the arrow head and at the point 
after moving the 'Drag me to feature' point to another location 
within the CAVE display 

69 

CAVE_TO8_034.3 CAVE shall move the point along the tick marks as the user 
advances forward or steps back through each frame 

70,72 

CAVE_TO8_034.4 The Distance Speed tool shall display the speed (in knots) and 
bearing (in degrees) at the arrow head 

69 
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CAVE_TO8_034.5 The Distance Speed tool shall display the speed (in knots) and 
bearing (in degrees) at the movable point 

73 

CAVE_TO8_035 CAVE shall contain the Home tool 75 
CAVE_TO8_035.1 The Home location shall be located at the latitude and longitude 

specified by localization 
77-80 

CAVE_TO8_035.2 The Home location shall be editable 76 
CAVE_TO8_035.2.1 CAVE shall allow the user to move the Home marker by holding 

down MB1 on the marker and dragging it to another location 
77 

CAVE_TO8_035.2.8 CAVE shall store the new Home location latitude and longitude 
location 

77-80 

CAVE_TO8_035.3 CAVE shall allow the user to display the range in miles and 
azimuth in degrees from the Home location  

81 

CAVE_TO8_036 CAVE shall contain a points tool 83 
CAVE_TO8_036.2 CAVE shall allow launch of Points tool from Points button on tool 

bar 
83 

CAVE_TO8_036.2.1 The Points tool shall load in Edit Mode 83 
CAVE_TO8_036.3 CAVE shall create a default point layout if user's configuration 

does not contain a point layout 
83 

CAVE_TO8_036.3.1 Default configuration shall consist of 10 points labeled A-J 
centered about user's home location 

83 

CAVE_TO8_036.4 CAVE shall display the points in Normal Mode 84 
CAVE_TO8_036.4.2 The Points in CAVE shall be uneditable while in Normal Mode 84 
CAVE_TO8_036.5 CAVE shall allow manipulation of Points through an Edit Mode 87 
CAVE_TO8_036.5.1 CAVE shall display the points in Edit Mode 83,85 
CAVE_TO8_036.5.1.1 CAVE shall display the label 'Interactive Points (Editable)' when 

the Points are in Edit Mode 
86 

CAVE_TO8_036.5.1.2 The user shall be able to move a point using mouse button 1 (click 
and hold ) on the point 

87 

CAVE_TO8_036.5.1.5 The user shall be able to delete a Point from the operations menu 
using mouse button 3 

88 

CAVE_TO8_036.6 CAVE shall allow toggling of modes using mouse button 2 on 
label describing layer (Interactive Points) 

84,85 

CAVE_TO8_036.7 In Edit mode, System shall persist the user's changes to the point.  
Points will be persisted as a localization object with the CAVE 
localization 

87-90 

CAVE_TO8_037 CAVE shall contain a Sunrise/Sunset tool 92 
CAVE_TO8_037.1 The Sunrise/Sunset tool shall allow the user to enter a Latitude 

value in the Latitude text box 
94 

CAVE_TO8_037.2 The Sunrise/Sunset tool shall allow the user to enter a Longitude 
value in the Longitude text box 

94 

CAVE_TO8_037.3 The Sunrise/Sunset tool shall allow the user to enter a Year value 
in the Year text box 

94 

CAVE_TO8_037.4 The Sunrise/Sunset tool shall allow the user to enter a Month value 
in the Month text box 

94 
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CAVE_TO8_037.5 The Sunrise/Sunset tool shall allow the user to enter a Day value in 
the Day text box 

94 

CAVE_TO8_037.7 The Sunrise/Sunset tool shall Calculate the Sunrise using the 
selected time Zone by using MB1 on the Calculate button 

94 

CAVE_TO8_037.8 The Sunrise/Sunset tool shall Calculate the Sunset using the 
selected time Zone by using MB1 on the Calculate button 

94 

CAVE_TO8_037.9 The Sunrise/Sunset tool shall Calculate the Azimuthal angles 
relative to true north of the sunrise using the selected date and 
location by using MB1 on the Calculate button 

94 

CAVE_TO8_037.10 The Sunrise/Sunset tool shall Calculate the Azimuthal angles 
relative to true north of the sunset using the selected date and 
location by using MB1 on the Calculate button 

94 

CAVE_TO8_037.11 The Sunrise/Sunset tool shall Calculate the total length of daylight 
for the given date by using MB1 on the Calculate button 

94 

CAVE_TO8_037.17 The Sunrise/Sunset tool shall automatically populate the Year, 
Month and Day text boxes with the current Year, Month and Day 

93 

CAVE_TO8_037.18 The Sunrise/Sunset tool shall default the time Zone to that set in 
the localization preferences 

93 

 
 
 

 


